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Preface

Whether your business creates electrical schematics, facilities
management drawings, network diagrams, architectural plans,
or maps to the company picnic, the Visio® Technical drawing
application has the tools you need—tools everyone in the
office can use.

In today’s technical office, a single drawing may be used by sev-
eral people in different departments: Manufacturing requires a
detail of the drawing to use on the assembly line. Sales revises a
drawing to use in a proposal. Management needs a copy for re-
view and redlining. Visio can accommodate these diverse
needs.

Using Visio Technical describes Visio’s powerful features using
step-by-step procedures. This preface describes how to get the
most out of the Visio Technical documentation.

Topics in this chapter

Who this Book Is For .................................................................. 2

What this Book Is About ............................................................ 2

Getting More Information ......................................................... 3
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W H O  T H I S  B O O K  I S  F O R

Using Visio Technical is for anyone who wants to learn how to
create drawings with Visio Technical. This book assumes that
you communicate with drawings, diagrams, technical schem-
atics, or architectural plans as part of your job and that you
might be familiar with drawing software or computer-aided
design (CAD) software.

In addition, this manual assumes you have used other
applications under Windows and are familiar with Win-
dows terminology and techniques.

W H A T  T H I S  B O O K  I S  A B O U T

Using Visio Technical describes how to create technical illustra-
tions and schematics using the templates, stencils, and drawing
tools in Visio Technical. Through conceptual discussions and
step-by-step procedures, you’ll learn how to work quickly and
efficiently in Visio. A glossary at the end of the book defines
new terms.

If you’re eager to begin, start with Chapter 1, “Creating a
Drawing.” It introduces key concepts that will help you work
effectively in Visio. If you’re new to Visio or you’ve used other
programs, such as CAD software, the Introduction offers spe-
cific information about how to learn Visio.

This manual is organized in roughly the order you create a
drawing: It starts with page setup details, then moves onto in-
creasingly detailed procedures for using masters and drawing
precise shapes with Visio’s drawing tools. Later chapters pro-
vide details about organizing drawings with layers, sharing
your output, and customizing your own shapes.

About Lorem Ipsum

Illustrations throughout this book use pseudo-Latin
nonsense words to show text in shapes. Doing so al-
lows Visio Corporation to use the same illustrations in
all Visio manuals worldwide, without having to trans-
late the text in the graphics. This saves time and
allows Visio to release products more quickly than
would otherwise be possible.
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G E T T I N G  M O R E  I N F O R M A T I O N

Depending on how you like to work, there are many ways to
get more information about Visio Technical and find the an-
swers to your questions.

Online Help displays detailed procedural and reference infor-
mation onscreen. It contains some information that does not
appear in this book, including a complete reference of menu
commands, toolbar buttons and tools, programming language
terms, and cells and sections in the ShapeSheet™ spreadsheet.

To display online Help in Visio Technical, do one of the following:

• Press F1.

• Choose a command from the Help menu.

• Click the Help button in a dialog box.

Shape Help describes how to use a shape’s special features. To
display Shape Help, right-click a shape on a page or a master
shape on a stencil, then choose Shape Help from the shortcut
menu.

Developing Visio Solutions is for anyone who wants to build
custom shapes or solutions with Visio. It describes how to pro-
gram in the ShapeSheet, and how to extend Visio using
Microsoft Visual Basic or other programming languages that
support OLE Automation.

If you have a CD-ROM drive, run the Quick Tour, an online
tour of Visio basics that takes less than 20 minutes to complete.
After viewing the Quick Tour, you’ll know how to start, build,
and print a drawing. To view the Quick Tour, choose Quick
Tour from the Help menu.

Wizards and add-ons do work in Visio Technical for you. They
can automate routine tasks, perform unique functions, and
create special drawing types from scratch. For example, the
Measure Add-on calculates the total perimeter and area of any
closed shape, such as a floor plan. To use a wizard or add-On,
choose Run Add-on from the Tools menu.

Add-ons like this one can perform special
calculations on shapes in a drawing.

Every Visio master shape includes Shape Help that
describes how to use the shape.
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In addition to the print and online materials that come with
Visio Technical, you can get assistance from a variety of other
sources. For example:

• To reach the Visio forum on CompuServe, type GO VISIO
at any ! prompt.

• To reach Visio using the Microsoft Network, from MSN
Central, choose Go To from the Edit menu, then type
Visio.

• To reach Visio using the World Wide Web, use the address
http://www.visio.com.

• To get technical support by fax, call (206) 521–4601.

• To speak with technical support representatives, call
Monday through Friday, 6 a.m.-5 p.m. Pacific Time, at
(206) 521–4600.
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Introduction

With its many job-specific stencils and more than 2000
SmartShape®� masters, Visio Technical is the solution to most
technical drawing needs—software diagrams, network dia-
grams, home designs, engineering schematics, space planning,
and business diagrams.

This chapter introduces you to important concepts for working
in Visio Technical.

Topics in this chapter

The Big Picture ........................................................................... 6

Stencils, Templates, and Solutions ............................................. 8

Working with SmartShapes ...................................................... 10

Solutions for Technical Drawings ............................................ 12

Working with Integrated Documents ...................................... 14

Visio and Other Programs ....................................................... 15
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T H E  B I G  P I C T U R E

In general, here’s how you work in Visio Technical to create a
drawing:

1 Start a drawing by opening a template.

Whether you’re drawing a schematic diagram or a scaled
space plan, a template sets up your drawing page and opens
specialized stencils containing the shapes you need to use.

2 Add shapes by dragging them from a stencil and dropping
them on the drawing page, or draw your own.

You can create additional shapes by using Visio’s drawing
tools on the toolbar. For example, with the pencil tool you
can draw lines and arcs, or edit vertices on a shape. You can
also open additional stencils to choose from a wider variety
of shapes.

3 Arrange shapes to create the drawing you want.

Onscreen, the grid helps you align shapes and the rulers give
you precise control. You can place guides and use the Align
and Distribute commands for quick alignments. Or use the
Size & Position command to enter exact coordinates.

4 Glue shapes so that they remain connected regardless of
where you move them.

When a drawing includes connected shapes, use glue to re-
duce the time it takes to revise. For example, use glue to
connect dimension lines to shapes you want to measure,
such as walls in a home plan.

Arrange shapes.

Open a template.

Add shapes.

Glue shapes.
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5 Add text to your drawing.

You can add text simply by clicking a shape, then typing.
With the text tool, you can type anywhere on a drawing to
add text. In addition, many technical drawings require a
title block, so Visio includes a stencil of assorted title block
styles from which to choose.

6 Modify the look of shapes.

Formatting shapes is quick with the style lists on the
toolbar. In Visio, a single style can apply text, line, and fill
attributes to a shape. You can define your own styles to add
to the toolbar lists.

7 Include your drawing in another program or print it.

Your drawing can become a key element in a PowerPoint
slide show, or a drawing in a Word document. Visio sup-
ports linking to and embedding in many other Windows
applications as well as converting to and from AutoCAD file
format.

Add text.

Format shapes.

Produce the drawing.
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S T E N C I L S ,  T E M P L A T E S ,  A N D  S O L U T I O N S

If your job involves creating technical drawings, you don’t have
to devote a lot of time or resources to learning complex CAD
programs. Visio Technical provides a powerful graphics engine,
an intuitive interface, and the drag and drop drawing tech-
nique for creating many types of industry-specific drawings,
from mechanical engineering schematics to landscape architec-
ture plans.

You can quickly create the type of drawing you need when you
start with one of Visio’s templates. A template includes every-
thing you need to create a drawing, from the drawing page to the
shapes and styles. Stencils alongside the drawing page contain
masters that you can drag onto the page to create a drawing. In
the drawing window, the grid and rulers ensure that shapes align
and resize precisely so that your drawing is technically accurate.
With Visio’s pencil, spline, and other tools, you can modify the
drawing to conform to your standards.

When you start Visio Technical and open a template, the Visio window opens
with a drawing page and one or more stencils.

Status bar

Toolbar

Stencil

Master shape icon

Drawing window

Drawing page
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Working with a template ensures consistency across your draw-
ing files. The template sets up your drawing page to specific
dimensions and sets the units of measure that appear on the
rulers. When you start a new drawing, you can focus on what
goes on the page; the template takes care of the rest.

When you need a shape that doesn’t appear on a stencil, you
can open another stencil that contains the shape you want,
start with a similar shape and revise it, or draw a custom shape
using Visio’s complete set of drawing tools. If you want to reuse
your custom shape in other drawings, you can then add it to a
stencil as a new master. You can even customize a template to
include a new or revised stencil or settings that better reflect
the standards you work with.

For details about customizing stencils and templates, see Chap-
ter 4, “Saving Time and Reusing Work.”
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With Visio Technical’s templates and drawing tools, you can create scaled plans
and dimensioned drawings in no time.

Industry-specific drawings

Visio Technical includes more than 2000 SmartShapes
on industry-specific stencils:

• Space planning

• Facilities management

• Construction drawings

• Heating, ventilation, and air conditioning

• Electrical schematics

• Process plant design

• Piping and instrumentation

• Networking and telecommunications

• Software engineering

• Mechanical engineering

• Manufacturing and assembly drawings

Visio Technical also includes all of the business
SmartShapes needed to create flowcharts, project
timelines, block diagrams, and more.
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W O R K I N G  W I T H  S M A R T S H A P E S

The easiest way to create a drawing in Visio Technical is to drag
shapes from a stencil to a drawing page. These shapes are
SmartShapes. SmartShapes are not static clip art images or
symbol libraries, but shapes programmed to act the way you
need them to in a particular context.

SmartShapes can actually help increase the accuracy of your
drawings. For example, shapes for doors, windows, appliances,
desks—things that are built to standard industry sizes—are
locked against resizing so you don’t accidentally stretch the
shape inappropriately. Other shapes perform calculations for
you. For example, the Ramp shape is programmed to recognize
the building code that indicates how steep a ramp can be. All
you need to do is enter the value for the rise (the height) and
the shape automatically calculates the required run (the
length). If the rise becomes too steep or the run becomes too
long, the Ramp shape warns you that a landing is required.

Using SmartShape Masters
Master shapes, or masters, are SmartShapes saved in a stencil so
that you can reuse them. When you drag a master from a sten-
cil, you create an instance of the shape on the drawing page.
Unlike objects in a CAD system, Visio shapes are not a collec-
tion of vectors. A shape is a sequence of line or curve segments
that connect the shape’s vertices. Each vertex is recorded by
Visio as a pair of x,y coordinates, which makes it possible to
create shapes with great precision.

The desk chair is a SmartShape that makes
rotation easier.
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Customizing Shapes in the ShapeSheet
To understand what makes a shape smart, it helps to know how
shapes are drawn and stored in Visio. Every Visio shape is
backed by a ShapeSheet spreadsheet that contains information
about the shape’s geometry and other properties. For example,
the ShapeSheet displays the coordinates of each shape vertex.
Much of this information can be defined by formulas rather
than simply by hard-coded numbers. This is important
because it’s what makes a shape really smart; formulas allow a
shape to respond differently in various situations.

To display a ShapeSheet, select a shape, then choose Show ShapeSheet from
the Window menu.

You can use Visio to create accurate drawings without ever
opening a ShapeSheet. However, for added precision with cer-
tain operations, particularly when you are drawing from
scratch, you may want to work in the ShapeSheet.

For details about working in the ShapeSheet, see Chapter 8,
“Customizing Shapes.”

For details about creating your own SmartShapes, refer to
Developing Visio Solutions.

Symbol libraries and SmartShapes

If you’ve worked in a CAD environment, you may be
familiar with technical drawing programs that use
symbol libraries, which contain pre-drawn elements
that represent objects. In Visio, stencils are the equiva-
lent of symbol libraries. Instead of symbols, stencils
contain SmartShapes designed to address a specific
drawing requirement.

Both symbols and shapes often represent objects in
the real world. Beneath the surface, however, the two
are vastly different. Fundamentally, each symbol is the
same as the next: It’s simply a collection of lines that
represent an object in a drawing. Behind every Visio
shape, however, is a ShapeSheet that makes the shape
smart.
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Ellipse tool

Rectangle tool

Freeform tool

Arc tool

Line tool

S O L U T I O N S  F O R  T E C H N I C A L  D R A W I N G S

When you need to customize shapes and drawings, Visio Tech-
nical contains the solutions you need. These include
specialized drawing tools, the ShapeSheet for customizing
shape behavior, and even a programming interface that enables
Visio to become a component of a broader software solution.

Solutions for Drawing Efficiently
A complete set of drawing tools helps you work quickly and
efficiently in Visio. On the toolbar, the drawing tools menu
contains tools for creating and revising the geometry in your
drawing. You can draw straight and curved lines, rectangles,
circles, and more. For example, the freeform tool on the draw-
ing tools menu provides the most powerful spline capability
available in a technical drawing application. With this tool, you
can draw smooth curves easily and precisely.  For details about
drawing in Visio, see “Drawing Shapes” in Chapter 2, “More
About Shapes.”

When you need to organize information in complex drawings,
you can create layers. Use layers to:

• Keep specific types of information together for global
editing.

• Lock some shapes while making others available for
revision or redlining.

• Preserve layers in imported drawings created in high-end
drafting programs such as AutoCAD. For details about
layers, see Chapter 6, “Organizing Shapes with
SmartLayers.”

Another important tool is the grid, which you can customize.
You can specify the spacing of the grid on your drawing page to
precisely duplicate the standard measurements you work with.
For example, you can create drawings for modular construc-
tion on a 2-cm-by-2-cm grid, or lay out cubicles in an office on
a 1-m-by-1-m grid. For details about grid lines, see “Using the
Grid” in Chapter 5, “Measuring and Dimensioning.”

Pencil tool



I N T R O D U C T I O N 13

Creating Custom Shapes
One of the most powerful features of Visio is the ease with
which you can create and customize masters. That’s particu-
larly important in technical fields in which drawings have to
meet specific industry or corporate standards. Using Visio’s
ShapeSheet spreadsheet, which contains formulas that define a
shape’s appearance and behavior, you can modify the shapes
that come with Visio or use the drawing tools and the
ShapeSheet to create shapes that are specific to your industry
or application.

For details about developing your own shapes, see Developing
Visio Solutions.

Building a System Solution

Technical drawings are typically used to convey graphic infor-
mation to a specific audience. Using Visio Technical and OLE
Automation, your drawings can convey a variety of data to a
wider network of people. For example, you can link a Visio
drawing to a database or spreadsheet application that stores
and analyzes information used in the drawing. (For instance,
you could generate a parts list and project cost analysis from an
engineering schematic.) You can also write programs that au-
tomate parts of the drawing process, retrieve information from
other sources to include in a drawing, or extend Visio’s capa-
bilities to meet a custom requirement.

Developing Visio Solutions provides a comprehensive guide to
controlling Visio through OLE Automation using program-
ming tools such as Microsoft Visual Basic. This book includes a
disk with a set of sample programs and stencils you can study
or use as a starting point for creating your own Visio applica-
tions. For a complete reference to the objects, properties, and
methods you use when programming Visio, see the Visio OLE
Automation Reference (PROGREF.HLP) on the Developing Visio
Solutions disk.



14 U S I N G   V I S I O   T E C H N I C A L

W O R K I N G  W I T H  I N T E G R A T E D  D O C U M E N T S

In Visio Technical, you can create drawings that stand alone, or
your drawings can work in combination with word-processing,
spreadsheet, and database programs.

Visio Technical is fully compatible with Microsoft Windows 95,
Windows 3.1, Windows NT, and OLE 2. For example, you can
use Visio Technical with the Microsoft Office Binder to create a
document that combines pages from several different applica-
tions. A single file can include pages from Visio, Microsoft
Word, and Microsoft Excel, and you can include Visio drawings
that have multiple pages in a Binder document.

Even if an original drawing wasn’t developed in Visio, you can
still put Visio’s power to work for you by converting AutoCAD
files and files in other formats to Visio format. Visio maps the
drawing’s coordinate space to a Visio drawing page and con-
verts block and entity data to comparable Visio elements, such
as masters and instances. After a file is converted to a Visio
drawing, you can modify the contents using any of the com-
mands and tools in Visio.

For details, see Chapter 9, “Converting AutoCad and Other File
Formats.”
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V I S I O  A N D  O T H E R  P R O G R A M S

If you have worked with CAD or other drawing programs, you
can learn Visio faster if you know how it is like and unlike the
tools you already know. This section presents an overview for
two products that you might be familiar with: AutoCAD and
CorelDRAW!.

For details, see Appendix A, “Visio Technical for AutoCAD and
CorelDRAW! Users.”

Visio Technical and AutoCAD
If you’ve used AutoCAD, you’ll find Visio Technical takes a dif-
ferent approach to drawing, but one that won’t take you long
to learn. For example, masters in Visio are similar to AutoCAD
blocks—but Visio masters are SmartShapes. A more basic dif-
ference is that in AutoCAD you usually choose a command,
which performs an action on an object. In Visio, you select an
object first, then choose a command to perform. There are also
key differences in how you set up page size and drawing scale.

Visio Technical and CorelDRAW!
If you have used CorelDRAW! to create technical drawings, you
have probably worked with layers, dimensioning, skewing (for
isometric drawings), and drawing scales. In general, you use
the drawing tools in CorelDRAW! to create “objects,” and then
you manipulate the objects. In Visio, objects are shapes, and
they come pre-drawn in the form of masters on stencils,
although you can draw shapes as well.

When you open CorelDRAW!, you see a blank drawing win-
dow within which is a “printable page.” When you open Visio,
you choose a template based on the type of drawing you want
to create. You can create a drawing without using a template in
Visio, but using a template sets up time-saving stencils and
page settings. Like CorelDRAW!, Visio has guidelines, rulers,
and a grid that you can use to arrange shapes on the drawing
page.
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Creating a Drawing

Because Visio Technical shapes reflect industry and practice
standards from a variety of technical disciplines, you can create
everything from engineering drawings to space plans with
simple Visio drag and drop drawing techniques.

This chapter helps you get started using Visio Technical. It
explains how to open templates and stencils, drag and drop
shapes, and take advantage of time-saving features such as
backgrounds, layers, and glue.

Topics in this chapter

Starting Visio Technical ............................................................ 18

Drag and Drop Drawing .......................................................... 20

Setting Up the Page ................................................................... 22

Creating Multiple-Page Drawings ............................................ 24

Creating Layers and Backgrounds ........................................... 26

Snapping and Gluing Shapes ................................................... 28

Selecting Shapes ........................................................................ 30

Saving Visio Technical Files ...................................................... 32
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S T A R T I N G  V I S I O  T E C H N I C A L

The best way to start a new drawing is to open a new drawing
file with a template. The benefits of using a template are:

• It opens one or more stencils containing related shapes.

• It creates a new drawing page using a grid and measure-
ment system, saving you the time it takes to set up pages.

• For drawing types that use a scale, such as 1:10, it sets up
the drawing page to scale.

• It copies related styles to the drawing file, saving you the
time it takes to define your own styles.

You don’t have to begin a drawing using a template. But begin-
ning with a template is a lot like starting out on a cross-country
car trip equipped with maps, hotel reservations, and an itiner-
ary from an automobile association. Some important things
are already set up for you, as the illustration below shows.

A drawing file based on a template opens with one or more stencils docked
alongside a drawing page.

B

E

F

A

D

G

C

Visio Technical window

A You can customize the Visio toolbar so that the
buttons conform to Microsoft Office, Lotus
SmartSuite, or Novell PerfectOffice standards.

B Text, Line, and Fill style lists include styles you
develop yourself.

C When you open a template or stencil, by default
stencils dock to the left of the drawing page and
cascade. To bring a stencil to the front, click that
stencil’s title bar.

D Vertical and horizontal rulers reflect the measure-
ment units set for your drawing.

E Stencils contain related masters that you can drag
and drop onto the drawing page.

F A status bar displays information about the pur-
pose of shapes and their position, size, or rotation
angle on the drawing page.

G A drawing page is set up with a size, orientation,
scale, grid, and measurement system appropriate
for a particular drawing type when you start with
a template.
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A

To open a new drawing file based on a template:

1. If you’re using Windows 95, click Start, choose Programs,
then choose Visio Technical.

If you’re using Windows 3.1x or Windows NT 3.51,
double-click the Visio Technical icon in the Windows
Program Manager.

2. In the New dialog box, under Based On, choose a template,
then click OK.

After you start a drawing, you can open additional stencils at any
time. By default, stencils are docked—that is, attached to the
drawing window so that they move when the drawing window
moves. You can dock stencils on either side of the drawing win-
dow or float a stencil instead, so that it appears in a window you
can move independently. To switch sides or float a stencil, right-
click a stencil’s title bar, then choose Float or Switch Sides.

To open additional stencils:

1. Choose Stencils from the toolbar or the File menu.

2. In the Stencils box, choose the stencil you want, then click
OK.

B

C

Stencils

Using a custom or no template

If the drawings you usually create require unique settings not available in any of Visio’s templates, you can open a drawing with no template, revise
an existing template, or create one of your own. To open a new drawing without basing it on a template, under Based On in the New dialog box,
choose No Template. An unscaled drawing page opens with no stencils.

For details about revising or creating a template, see “Creating New Templates” in Chapter 4, “Saving Time and Reusing Work.”

To minimize a floating stencil so you see only its
title bar, click the stencil's minimize box.

Close box

Minimize box

New dialog box

A Choose the template you want to base your
drawing on.

B When you select a template from the box, read
for a description.

C Click to browse for other templates or drawing
files saved on your computer.

D By default, Visio starts a new drawing file, but
you can also create a new stencil file.

D
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D R A G  A N D  D R O P  D R A W I N G

The easiest way to create a drawing in Visio is to drag shapes
from a stencil to a drawing page. This method is called drag
and drop drawing.

Stencils are collections of master shapes, or masters. When you
open a stencil, you see its master shape icons on a green back-
ground. When you open the drawing window, you see the
drawing page—which looks like a piece of paper—on a blue
background. You drag a master from the stencil to the drawing
page and drop an instance of the master into your drawing.

To drag and drop a shape:

1. Point to a master shape on the stencil, then hold down the
left mouse button and drag the shape into the drawing
window. Release the mouse button to drop it, creating an
instance.

As you point to a master in a stencil, you can refer to the
status bar for information about that master.

Stamping is often the easiest way to create multiple instances of
a master.

To stamp a shape:

1. From the connection tool menu, choose the stamp tool.

2. In the stencil window, click a master to select it.

3. In the drawing window, place the pointer where you want
the center of the shape.

4. Click the left mouse button to create an instance.

5. Repeat steps 3 and 4 for each instance you want.

To move a shape:

1. Point inside a shape so that the pointer turns white.

In addition to the pointer tool, you can use any of the
following tools to move a shape: crop, rotation, connection
point, stamp, and all the drawing tools.

2. Drag the shape where you want it.

Stamping connectors and walls

Stamping can quickly place several walls, connectors,
or other 1-D shapes of various lengths and at various
angles in your drawing. Using the stamp tool, click a
1-D master shape. In the drawing window, hold down
the left mouse button and point to where you want
one end of the shape. Drag to draw the shape at the
angle and length you want. Release the mouse button.
Repeat for each instance you want.

IBM AS/400

IBM AS/400

IBM AS/400

IBM AS/400

Dragging and dropping to create a drawing can be
as accurate as it is fast when you use the grid
and rulers to position shapes.

Stamp tool
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For details about working with shapes on the page, see
Chapter 2, “More About Shapes.”

To resize a shape:

1. While the shape is selected, drag one of the green handles on
the shape. Corner handles resize the shape proportionally.

For details about using handles on shapes to control shapes, see
“Shape Anatomy” in Chapter 2, “More About Shapes.”

For details about how to connect two shapes, see “Connecting
Shapes” in Chapter 2, “More About Shapes.”

You may need to zoom in on or out from the page, depending
on your task. To change the view, choose Zoom from the View
menu or choose an option from the Set Zoom list on the
toolbar. For a list of view shortcuts, see “Setting the Drawing
Scale” in Chapter 5, “Measuring and Dimensioning.”

You can customize the ruler, grid, and other features to help
you draw precisely. For example, you can change the measure-
ment units on the rulers, move the zero point on the rulers,
and set a fixed grid whose increments do not vary as you zoom
in and out. For details, see Chapter 5, “Measuring and Dimen-
sioning.”

When you drop an instance of a master, Visio snaps the shape
to the nearest grid line or ruler subdivision so that you can
place it precisely. For details, see “Snapping and Gluing Shapes”
later in this chapter.

The masters you drag from a stencil are SmartShapes, shapes
with special behavior. To find out what a SmartShape can do,
right-click the shape, then choose Shape Help from the short-
cut menu.

The pointer changes from black to white when you
place it over a shape, indicating that you can drag
the shape. Faint lines on each ruler also indicate
the shape’s location.

To place the shape more precisely, pause while
dragging to see the shape instead of the box or
line representing it.

For even greater accuracy in placing shapes, use the
Size & Position command on the Shape menu.
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S E T T I N G  U P  T H E  P A G E

If you start a drawing by opening a template, the template in-
cludes page settings that affect how you work in a drawing and
how it prints. When you draw in Visio, the white page you see
onscreen is the drawing page. When you change page settings,
you control the dimensions of the drawing page, the printed
page size, and its orientation. These settings define the rela-
tionship of the onscreen dimensions to the real world, which
determines whether everything you’ve drawn onscreen will fit
on the paper when you print.

If you have more information on a drawing page than can fit
on the printed page, you can:

• Change the drawing orientation to see if everything will fit.

• Set a drawing scale that represents larger real-world
dimensions in a smaller scaled space.

• Choose a larger printed page size.

If the drawing represents real-world objects too large to fit at
their actual size on a piece of paper, or too small to depict, you
must set a drawing scale.  The ratio of the shape’s dimensions
as they appear onscreen to their real-world measurements de-
fines the scale. For example, in an architectural plan, the
drawing scale might be 1:10, where 1 m onscreen represents 10
m in the real world.

Differences between Visio and CAD

Visio differs from CAD systems, in which the onscreen
page has virtually infinite dimensions, and only when
users want to print do they consider printed page size.
In Visio, you set the size of the printed page first, so
that as you draw, the page always shows you exactly
what you will see when you print.
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If drawing size and printed page size differ, a
large drawing prints across multiple standard laser
printer pages.
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Changes you make to drawing page settings aren’t
automatically reflected in printer page settings.
Before you print, make sure settings, such as
orientation, are the same for both the drawing
and printed page.
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To set drawing size, orientation, and scale:

1. Display the drawing page with settings you want to change,
choose Drawing Page from the Edit menu, then choose
Size & Scale.

2. In the Drawing Size/Scale dialog box, under Drawing Size,
choose the page orientation and size options you want.

3. Under Drawing Scale, click the type of scale you want, then
choose a particular scale from the scale list, or click
Custom Scale, then enter a custom scale.

Changes you make to drawing page settings aren’t automati-
cally reflected in printer page settings. If you have changed the
drawing page size or scale, set the printed page size as well.

To set printed page size and orientation:

1. From the File menu, choose Page Setup.

2. In the Page Setup dialog box, choose the size and orienta-
tion you want for the printed page, then click OK.

The display at the top of the dialog box shows the effect of
your choices.

Drawing Size/Scale dialog box

A Click to choose a standard, metric, or ANSI size
for the drawing page, then choose the size from
the Page Size list.

B Click to force the drawing size and orientation to
match the printed page size settings as estab-
lished in the Page Setup dialog box.

C Click to enter custom dimensions for the drawing
page, then type the dimensions you want.

D Click to make the drawing page size the size of a
rectangle that tightly encloses the shapes on it.

E If you’re drawing to scale, click to enter custom
dimensions (for example, 10 m x 30 m) for the
scaled drawing page.

B

D

C

A

E
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C R E A T I N G  M U L T I P L E - P A G E  D R A W I N G S

For some drawing projects, you may want to create a single
drawing file that contains many drawing pages. For example, a
file could represent a construction project with the overall
floor plan on one drawing page, a detailed view on another
page, and the plan for walls and doors on another page. New
drawings in Visio Technical open with only one drawing page,
but you can add as many new pages as you want.
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Each page in a multiple-page drawing can have its own settings. For example,
each page can have a different drawing scale.

When you create a new drawing page, it inherits the size, orien-
tation, scale, measurement unit, shadow offset, ruler, and grid
settings of the page currently displayed in the drawing window.
When you display the new page, you can change its settings, if
necessary.
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To create a new page:

1. Display a page you want to base the new page on, then
choose Page from the Insert menu.

2. In the Page dialog box, name the page or use the name
Visio assigns.

3. Set measurement units and shape shadow offsets if you
want, then click OK.

Visio inserts the new page after the original page and
displays the new page in the drawing window. To reorder
drawing pages, choose Drawing Page from the Edit menu,
then choose Reorder.

To navigate between pages:

• Click the Next Page button.

• Click the Previous Page button.

• Choose Go To from the Edit menu.

At lower screen resolutions, the paging buttons aren’t visible on
the Visio toolbar. If you right-click the toolbar and choose Lo-
tus SmartSuite from the menu, the Next Page and Previous
Page buttons are visible at lower screen resolutions.

For details about creating custom navigational links, see “Link-
ing Shapes to Pages and Files” in Chapter 8, “Customizing
Shapes.”

Displaying pages simultaneously

To open the new page in a new window so you can
display both the original page and the new page at
once, check Open Page In New Window in the Page
dialog box. To activate the window containing a draw-
ing page, click its title bar.

When you display pages side-by-side, you can quickly
move shapes between pages by dragging. To do this,
activate the window containing the shape, then drag
the shape between the windows. To copy a shape,
hold down the Ctrl key before you drag it between
windows.

For details about displaying pages, search online Help
for “pages: displaying.”

Next Page

Previous Page
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C R E A T I N G  L A Y E R S  A N D  B A C K G R O U N D S

To help set up your drawing efficiently, you can assign shapes
to layers or place shapes on a background. A layer is a category
of shapes on a page. A background is a page that appears behind
another page. Both layers and backgrounds help you organize
information in your drawing, but you use them for different
reasons:

• Create layers when you want to control categories of shapes
and text on the same drawing page.

• Create a background when you want the same shape to
appear on more than one drawing page.
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A background is a page; therefore, its attributes, such as scale, size, and
layers, can differ from other pages—including the pages to which the
background is assigned.

Shapes on some stencils, such as space planning, are already as-
signed to layers. When you drag these shapes onto the drawing
page, the shapes’ layers are added to the drawing as well. You
can work selectively with shapes based on their layer assign-
ments, such as viewing only the shapes assigned to one layer.Layers in CAD Drawings

Visio drawings are different from many CAD drawings,
which always use layers. In Visio, you don’t have to
use layers, and when you do, you can easily create
and delete layers and assign and reassign shapes to
them. You can even assign the same shape to as many
different layers as you want.

Walls layer Furniture layer
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Dimensions layer All three layers visible

Assign shapes to layers so that you can selectively
view, edit, print, or lock shapes based on their layer
assignments.

28 68

30 68

26 68

26 68

26 68

28
68

28 68

30
68

26 68

26 68

26
68

28
68

Fe
ug

ia
t 

nu
lla

 f
ac

ili
si
s

Fe
ug

ia
t 

nu
lla

 f
ac

ili
si
s

Fe
ug

ia
t 

nu
lla

 f
ac

ili
si
s

03 05 07

315

0

1270
m m

18

16

14

12

10

400

0
480
0

43
5 5

17
7 0

01

15
0 0

79

7

170
0

55 0

37
9 5

08

32
3 0

70
4 5

14
5 0

22
1 0

126

7

3591. 4

3

145

0

108

0

180

0

51

5

53

0

01

02

03
04

05

06

07

11
0 0

20
0 0

25 9

18
0 0

Use a background when you want to repeat a
common graphical element on several drawing
pages.



C R E A T I N G   A   D R A W I N G 27

When you add shapes to a background, they are also visible on
the pages to which that background is assigned. For example,
you can place the title block and border for a drawing on the
background, so that these common elements appear on all the
pages to which the background is assigned. Each drawing page
can have one background assigned to it. A background can also
have a background assigned to it.

To create a background and assign it to a page:

1. From the Insert menu, choose Page.

2. In the Page box, under Type, click Background.

3. To set unique page attributes for the background, click
Size/Scale, choose the options you want, then click OK.

If you don’t click Size/Scale, Visio uses the same size and
scale as the last displayed page.

4. Under Name, type a name you want or use the name Visio
assigns, then click OK.

Visio displays the new background in the window.

5. From the Edit menu, choose Go To, then choose the name
of the page to which you want to assign the background.

6. From the Edit menu, choose Drawing Page, then choose
Properties.

7. In the Page Properties box, from the background list,
choose the background you want to assign, then click OK.

Any shapes on the background appear on the drawing
page. To work with background shapes, use the Go To
command again to display the background.

For details about working with backgrounds, search online
Help for “background pages.”

For details about creating and working with layers, see
Chapter 6, “Organizing Shapes with SmartLayers.”

Comparing layers and stacking order

Visio SmartLayers are not layers in the sense of stack-
ing order. As you add shapes to a page, the stacking
order determines how shapes overlap. Regardless of
layer assignments, the first shape you add is at the
back, the next shape is one forward, and the last
shape you add is at the front. If all the shapes have a
fill, you can see how they overlap.

Pages, too, appear to stack, in that a background is
always “behind” the page to which it is assigned. In
this sense, pages and backgrounds function like over-
lapping layers of mylar. A page is transparent, so all
the shapes on the background will show through on
the foreground.

Visio SmartLayers let you define categories of shapes
that you can work with. Shapes that are assigned to
layers overlap according to their stacking order. Layer
assignments have nothing to do with which shape
appears to be at the front.
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S N A P P I N G  A N D  G L U I N G  S H A P E S

Creating a drawing involves moving and positioning shapes on
a drawing page. When speed and precision count, you can drag
shapes and rely on Visio’s snap behavior to position them ex-
actly. Snapping pulls shapes to one another or to ruler
subdivisions, grid lines, guides, or guide points so that you can
control placement and alignment. Use snap when you want to
precisely align shapes with other shapes or objects on a draw-
ing page.

To ensure that shapes that need to stay together do so when
you move them, use glue. For example, in a network diagram,
you need to be able to rearrange hardware shapes without
breaking their network connections. By default, all 1-D shapes
(lines, connectors, and anything that looks like a line when you
drag it) can glue to 2-D shapes (rectangles and anything that
looks like a box when you drag). To glue shapes, you drag a
1-D endpoint to a 2-D selection handle, connection point, or
other point you define.

Used together or separately, snap and glue help you lay out
shapes precisely and quickly on a page. Visio snaps shapes by
default and glues to guides and connections points, but you
can change settings to control when to snap and glue, what ob-
jects shapes snap or glue to, and snap and glue strength, which
is the amount of pull (measured in pixels) that an object, such
as a grid line, exerts.

To help you position shapes precisely, you can
choose which, if any, objects a shape snaps to, such
as grid lines or ruler increments.

Glued endpoint

When the endpoint on one shape glues to a handle
or connection point on another shape, the endpoint
turns red.
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To set how shapes snap and glue:

1. From the Tools menu, choose Snap & Glue.

2. In the Snap & Glue dialog box, choose the options you
want, then click OK.

The settings you choose apply to all shapes on the current
drawing page. If you have more than one page in your
drawing, you can set different snap and glue options for
those pages.

Tip: To place shapes as precisely as possible, set a strong
snap strength, zoom in on your drawing, then move the
shapes into place.

For details about using glue to connect shapes, see “Connecting
Shapes” in Chapter 2, “More About Shapes.” For details about
other methods of drawing with precision, see Chapter 5, “Mea-
suring and Dimensioning.”

D

Snap & Glue dialog box

A Check to turn Snap and Glue on. Uncheck to
turn them off.

B Check to determine what to snap to.

C Check to determine what to glue to.

D Slide a bar to change the amount of pull an
option exerts. Increase ruler strength in relation
to grid strength when you want shapes near
both a ruler subdivision and grid line to pull
to the ruler. “Points” refers to selection
handles, vertices, and connection points.

When not to snap

You may not always want to snap shapes. For ex-
ample, by turning off snapping, you may find it easier
to draw a smooth freeform curve. You can also turn
off some snap options when you want shapes to glue
to one particular type of object. For example, when
you want shapes to snap only to guides, turn off the
Snap To Grid option.

A
B

C
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S E L E C T I N G  S H A P E S

To work with a shape, you must usually select it first. For ex-
ample, to flip a shape, you first select it. To group several
shapes together, you first select them. In most cases you’ll select
shapes using the pointer tool. You can also use other drawing
tools to select shapes; for example, you can use the rotation
tool to select a shape in addition to rotating it.

You can select several shapes to affect all of them at once. When
you select multiple shapes and then apply a command, the re-
sult is affected by the order in which you selected the shapes
and the shapes’ stacking order. The first shape you select in a
multiple selection is the primary shape. It determines what
happens to the other selected shapes in a multiple selection:

• The primary shape’s attributes determine what appears in
any dialog boxes or styles you display.

• The position of the primary shape determines how all the
shapes align when you use the Align Shapes command.

• The primary shape determines the order in which shapes
connect when you use the Connect Shapes command.

Stacking order is the order in which shapes are added to a draw-
ing page, and it determines which shape appears to be in front
of another if they overlap. When you type in a group, the text
appears in the frontmost shape.  You can change the stacking
order to add text to other shapes. The first shape you draw or
drop on a page is at the back in the stacking order; the last, or
most recently added, shape is in front.

For details about creating groups, see “Grouping Shapes” in
Chapter 2, “More About Shapes.”

Selecting in CorelDRAW!

In CorelDRAW!, the last object selected always serves
as the reference point. In Visio Technical, the first ob-
ject selected serves as the reference point (that is, the
primary shape). Unlike CorelDRAW!, Visio indicates the
order in which objects were selected: Green selection
handles show the first object selected, light blue selec-
tion handles show objects subsequently selected.

When you shift+click to select multiple shapes,
the shape you select first is primary.

When you select a group and type text, the
stacking order of the group’s shapes determines
where your text appears.

Lorem Ipsum

When you select shapes by dragging a selection
net around them, the primary shape is the one at
the front of the stacking order.
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Methods for selecting shapes

To Do this

Select one shape Click the shape with the pointer tool. The shape’s selection handles

turn green.

Select multiple shapes by clicking Select the first shape, hold down the Shift key, then click to select

other shapes one at a time. The primary shape has green selection

handles, and all other shapes have light blue selection handles.

Select multiple shapes by dragging With the pointer tool, drag a selection net around all the shapes you

want to select. The shapes appear selected as described above.

Select all the shapes on the page From the Edit menu, choose Select All. If there are many shapes, they

appear with a magenta outline to show that they are selected.

Otherwise, the shapes appear selected as described above.

Select all of a particular kind of object, From the Edit menu, choose Select Special, then check the type

such as shapes, groups, guides, etc. of object you want to select. The shapes appear selected as described

above.

Cancel a selection Click away from the selected shape.

Cancel the selection of one shape Shift+click the shape.

when several are selected

Methods for changing a shape’s stacking order

To Do this

Bring a shape forward in the stacking order Select the shape, then choose Bring Forward from the Shape menu.

Bring a shape to the front in the stacking order Select the shape, then choose Bring To Front from the Shape menu

(or press Ctrl+F).

Send a shape backwards in the stacking order Select the shape, then choose Send Backward from the Shape menu.

Send a shape to the back in the stacking order Select the shape, then choose Send To Back from the Shape menu (or

press Ctrl+B).

Change the stacking order of a shape in a group Select the group, then choose Open Group from the Edit menu.

Select a shape, change its stacking order as above, then close the

the Group window.
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S A V I N G  V I S I O  T E C H N I C A L  F I L E S

How you save a Visio Technical drawing file (*.VSD) influences
what happens when you open it. You can:

• Enter file properties, such as title, creator, keywords, and
description. When you save a file for the first time, Visio
prompts you for this information. Properties appear in the
Open dialog box when you select a filename to help you
identify a file before opening it.

• Save the workspace when you save a drawing file. When
you next open the file, the stencil and drawing page
windows will look just as they did when you saved the file.

• Save a drawing file as a template (*.VST) that you can use as
a model for other drawings.

• Save a drawing file in Visio 2.0, 3.0, or 4.0 format. When
you open the file in an earlier version of Visio, any infor-
mation specific to Visio 4.1 will be lost. For details, see
“Earlier versions of Visio” on the next page.

• Save a file as read-only to prevent its being inadvertently
edited or changed.

• Export a Visio Technical file in AutoCAD, Windows
Metafile, Encapsulated PostScript, and other formats.

For details about exporting Visio files, see Chapter 9, “Convert-
ing AutoCAD and Other File Formats.”

The first time you save a file, the Save As dialog box appears, in which you
can choose a filename, type, format, version, and location.

A

C
B

Save As dialog box

A Choose the file type, format, and version.

B Check to prevent the file from being modified next
time it’s opened.

C Check to save the arrangement of stencil and drawing
page windows as well as the file content. This option
is checked by default.
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To save a drawing file for the first time:

1. From the File menu, choose Save or Save As.

2. In the Save As dialog box, type a name for the file, choose a
location, and choose a file type, format, and version.

3. Click Save.

4. In the Properties dialog box, fill in properties information
for the file, then click OK.

Tip: To quickly save changes to a file you’ve already saved,
click the Save button on the toolbar or press Ctrl+S.

Earlier versions of Visio

You can save a Visio Technical 4.1 drawing file in a format that can be opened in an earlier version of Visio. However, you may lose some informa-
tion that the earlier version does not support. If you save a 4.x file in 4.0 format, no information is lost.

If you save a 4.1 file in 3.0 format, then open it in Visio Technical 3.0:

• Layers from the 4.1 file disappear. Layer assignments are lost.

• Curves created with the freeform tool are converted to arcs.

• Line ends particular to 4.1 disappear. Lines appear without those line end styles.

• A fixed grid is converted to a variable grid.

If you save a 4.1 file in 2.0 format, then open it in Visio 2.0:

• The features listed above are converted as specified.

• Any shapes connected with dynamic glue are no longer connected.

• File size increases.

• Lotus Notes support is lost. Data fields you added in which Visio included Lotus Notes information are no longer automatically updated.

In addition, when files are opened in earlier versions of Visio, Shape Help, control handle ToolTips, the wizards, and several shape operations (inter-
sect, subtract, trim, join, fit curve, custom fit) are no longer available.
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More About Shapes

This chapter explains more about what shapes are and how to
work with them: how to connect, format, duplicate, rotate, and
arrange them on the page. It covers the handles on shapes, and
what they are used for. In addition, this chapter explains how
to draw new shapes, create new shapes by merging two or more
shapes together, and revise existing shapes.

For details about programming your own shapes with smart
behavior, see Developing Visio Solutions. For details about sav-
ing shapes to stencils and creating your own templates, see
Chapter 4, “Saving Time and Reusing Work,” and Developing
Visio Solutions.

Topics in this chapter
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Shape Anatomy ......................................................................... 38

Connecting Shapes ................................................................... 40

Grouping Shapes....................................................................... 44
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Drawing Shapes ........................................................................ 60

Merging Shapes to Create New Ones....................................... 62
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W H A T  S H A P E S  A R E

The term shape refers to one line, arc, or spline; a series of line,
arc, or spline segments; or several shapes grouped together.
Shapes include masters on stencils that come with Visio and
shapes you draw on the drawing page. Visio Technical masters
typically have “smarts”—additional behavior programmed
through the ShapeSheet. You can add similar behavior to the
shapes you create.

Things you can do with any shape
With any shape, you can do these things (unless the shape has
been locked against a specific behavior):

• Resize, move, flip, or rotate it.

• Change its stacking order relative to other shapes.

• Format it and add text to it.

• Glue it to other shapes and guides.

• Revise it by adding segments or changing the way it curves.

• Control how it appears on the screen, whether it prints,
how it resizes in a group, and how it behaves when you
double-click it.

• Associate it with data and use the data to generate reports.

• Control its behavior by modifying its ShapeSheet.

A single line is a shape, as is a rectangle. The
table with chairs is a Visio Technical master
composed of simpler shapes grouped together.

A shape is either open or closed. You can fill
closed shapes with colors or patterns. You can add
line ends, such as arrowheads, to open shapes.
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Methods for creating a new shape

There are several ways to create a new shape:

• Edit an existing shape.

• Draw the shape from scratch.

• Group shapes.

• Merge a shape with other shapes to create new, unique
shapes.

• Create a new shape from scratch in the ShapeSheet.

Methods for changing shape behavior
If you want a shape to behave in a special way, you can change
its behavior. To make the most significant and detailed
changes, you use the ShapeSheet. However, there is an easy way
to make several behavioral changes: Use the SmartShape Wiz-
ard. The wizard guides you through the process of customizing
a shape’s text, creating built-in connectors, defining custom
properties, and defining other behavior. Choose Run Add-on
from the Tools menu, then choose SmartShape Wizard.

A

An example of a SmartShape. Dragging control
point A changes the length of a screw’s threaded
section while the screw remains the same size.
This behavior was programmed into the shape’s
ShapeSheet.
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S H A P E  A N A T O M Y

You can adjust shapes in a variety of ways by dragging their
handles. Each handle adds to the power of the shape and to the
ease of creating a drawing. This section explains what various
handles can do.

Selection handles and endpoints appear when you select shapes
with the pointer tool. To resize a shape, drag its selection
handles or endpoints.

Most shapes are two-dimensional (2-D) shapes. Two-dimen-
sional shapes have corner selection handles that you drag to
resize the shapes proportionally.

Two-dimensional shapes

Some shapes, including all connector shapes, are one-dimen-
sional (1-D) shapes. One-dimensional shapes have
endpoints—a beginning point with an × and an ending point
with a +—and they behave like lines. To connect 2-D shapes,
glue the endpoints of 1-D shapes to points on the 2-D shapes.

M

One-dimensional shapes

Selection handles

Endpoint

Selection handles
Selection handles are green on the primary
selection and light blue on subsequently selected
shapes. Drag them to resize shapes.

Beginning point

Ending point
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Rotation handles appear when you select a shape with the rota-
tion tool. To rotate a shape, drag a handle. To change the center
of rotation, drag the pin, which marks the center of rotation.

Vertices appear when you select a shape with the pencil, line,
arc, or freeform tool. To reshape a shape, drag a vertex. To add
or delete segments, use the pencil tool to add or delete vertices.

Control points appear on lines, arcs, and freeform curves when
you select them with the pencil tool. You can use control points
to change the curvature or symmetry of a segment.

Some shapes have connection points. Glue the endpoints of 1-D
shapes to connection points (or to other points) on 2-D
shapes. You can also create new connection points using the
connection point tool.

Some shapes have control handles. Each control handle has a
function unique to the shape it’s on. To see a tip about what a
control handle does, pause the pointer over a control handle.

Chair rotation

A control handle

Padlocks on a selected shape indicate the shape is locked against
specific changes. Some shapes are locked against flipping, ro-
tating, resizing, or other changes that would destroy their
integrity.

Vertex

Control point

Vertices and control points. On curved segments,
an × appears in the control point.

Connection points appear as blue ×s on a selected
shape.

Connection point

Pin

Rotation handles

A locked shape
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C O N N E C T I N G  S H A P E S

Technical schematics often show connections between shapes.
For example, a fluid-power petroleum-process drawing might
use connected shapes to trace the flow of oil through compres-
sors, catalyst cases, and fractionators. A network drawing
might display the peripheral devices connected to a local area
network.

In Visio, it’s easy to maintain connections by using glue. Once
shapes are glued, you can move the shape to which another
shape (such as a connector) is glued without breaking the con-
nection.

You can choose from among several methods for gluing
shapes. Depending on the type of drawing you want to create,
one method might be more appropriate than others. You can
control whether to glue entire shapes or specific points on
shapes. You can even add new points on shapes to which other
shapes can be glued.

Use glue to connect shapes when:

• You want a specific point on one shape to stay connected to
a specific point on another. Most 1-D shapes, such as
connectors, glue in this manner using static glue.

• You want a specific point on one shape to stay connected to
any point on another shape.

• You want any point on one shape to stay connected to any
point on another. The Universal Connector glues in this
manner using dynamic glue.

To connect two 2-D shapes using a connector shape:

1. Drag an endpoint of a 1-D connector shape to a connec-
tion point, selection handle, or other point you define on
one of the 2-D shapes.

2. Repeat step 1 to glue the other endpoint of the 1-D shape
to a point on the other 2-D shape.

By default, 1-D shapes have endpoints that you
can glue to 2-D shapes.

Some shapes have control handles that you can
drag to glue to other shapes.

By default, 1-D endpoints and control handles glue
to connection points (blue ×s) on shapes. You can
also choose to have endpoints glue to selection
handles and vertices, and you can add new
connection points.

Connection point
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Two types of glue

Static glue. You can tell when you glue to a specific point on a shape because
a box appears around that point. If you move the shapes, the two specific
points remain glued.

Dynamic glue. You can tell when you glue to an entire shape because a box
appears around the shape. If you move the shape, the connector also moves
to glue the closest points on the connected shapes.

Best methods for using glue in various drawing types

Drawing type Do this Type of glue

Electrical engineering Drag and drop a 1-D shape, then glue its endpoints to points on the Static

shapes you want to connect.

Network diagrams Drag and drop a shape with connector control handles, Static

then glue the control handles to points on other shapes.

Process flow diagram Select the shapes on the drawing page that you want to glue, then Dynamic

choose Connect Shapes from the Tools menu.

Flowchart Choose the connector tool on the toolbar, then drag and drop the Dynamic

shapes you want to glue.

Process flow diagram Drag and drop two shapes you want to glue. From the connection Static

or flowchart tool menu, choose the stamp tool. On the stencil, click a 1-D connector

shape. On the drawing page, position the pointer over a point or handle

on one shape and drag to a point or handle on the other shape.
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To convert static glue to dynamic glue:

1. Hold down the Ctrl key.

2. Drag a connector endpoint away from a connection point,
then drag it back again.

Tip: To convert dynamic glue to static glue, repeat the same
procedure but don’t hold down the Ctrl key.

To add a connection point to a shape:

1. Select the shape you want to add a connection point to.

2. From the connection tool menu on the toolbar, choose the
connection point tool.

3. Hold down the Ctrl key and click on, inside, or outside a
shape’s boundaries.

Tip: To delete a connection point, click the point with the
connection point tool and then press the Delete key.

Connection point tool

Making the right connections

Not all 1-D connector shapes can use dynamic glue. To
determine whether a connector is capable of dynamic
glue, hold down the Ctrl key while you glue to a point
on a shape. If a box appears around the point rather
than around the shape, the connector can’t glue
dynamically. When you must have dynamic glue, use
the Universal Connector shape, which is capable of
both static and dynamic glue.
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To specify what 1-D connectors can glue to:

1. From the Tools menu, choose Snap & Glue.

2. Make sure the Glue option under Currently Active is
checked.

3. In the Snap & Glue box, under Glue To, check the options
you want, then click OK.

Tip: Options you set in the Snap & Glue box don’t affect
connections you make with the Connect Shapes command
or with the connector tool.

For more details about glue, see “Snapping and Gluing Shapes”
in Chapter 1, “Creating a Drawing.” For details about end-
points, selection handles, and other shape parts, see “Shape
Anatomy” earlier in this chapter.

A B
C

D

E

Snap & Glue dialog box

A Check to glue endpoints to guides. This option is
checked by default.

B Check to glue endpoints to selection handles on
shapes, groups, or objects from other applications,
or to other 1-D shape endpoints.

C Check to glue endpoints to vertices on shapes.

D Check to glue endpoints to connection points
(blue ×s) on shapes. This option is checked by
default.

E Drag the box in the appropriate bar to increase or
decrease glue strength. If you make Guides strength
stronger than Points strength, an endpoint snaps to a
guide when a guide and point are near one another.
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G R O U P I N G  S H A P E S

In Visio Technical, you can group shapes so they function as a
unit. It’s useful to group shapes when you regularly use them
together or when you want to move, size, rotate, or format
them all at once. Also, by grouping shapes, you can create
shapes that have more than one formatting attribute, such as
shapes that have several colors. You can group any combina-
tion of Visio Technical shapes and shapes you draw yourself.
Groups can also include guides and objects from other applica-
tions.

You can move and resize a group as a single shape, and you can
edit the shapes in a group individually by opening the group
window and setting behaviors for how a shape will act relative
to the group it’s in.

A group has a ShapeSheet; so does each shape and object in the
group. For details about ShapeSheets, see Developing Visio
Solutions.

The tables on the following pages explain how to work with
groups.

You can choose Behavior from the Format menu to control how each shape
sizes relative to the group: Either it sizes when the group is sized or it stays
the same regardless of what happens to the group.

Some Visio Technical shapes are groups—that is,
simple shapes grouped to create complex ones.

After you add or delete shapes, the rectangle that
appears when you select a group may no longer
fit its dimensions. To adjust the rectangle, choose
Update Alignment Box from the Tools menu.

➊ ➋

➌ ➍

Behavior dialog box

A Click to have the shape resize when you
resize the group.

B Click to change the shape’s position but keep
the shape’s original size when the group
resizes.

C Default setting for shapes.

A

C
B



M O R E   A B O U T   S H A P E S 45

Methods for working with groups

To Do this

Group shapes and objects Select the shapes and objects you want to group. From the Shape

menu, choose Grouping, then choose Group.

Ungroup shapes and objects Select a group. From the Shape menu, choose Grouping, then choose

Ungroup.

Change the way a group looks Select the group. Resize, add a fill, or change the line style for the

group the way you would for any other shape. All shapes in the group

change.

Resize a group Select the group, then drag a selection handle to resize all the shapes

in the group at the same time (depending on each shape’s Resize

Behavior in the Behavior dialog box).

Change the way an individual shape Select the group, then click the shape you want to change to subselect

within a group looks it. The subselected shape has gray selection handles. Add a fill, or

change the shape’s line style.

Resize an individual shape within a group To open the group window, select the group, then choose Open

Group from the Edit menu. Select the shape you want to resize and

drag a selection handle to resize it. Click the group window’s close box.

Revise grouped shapes using the pencil tool To open the group window, select the group, then choose Open

Group from the Edit menu. Choose the pencil tool, select the

shape, then edit it as you would any other shape. Click the group

window’s close box. For details about editing shapes, see “Revising

Individual Shapes” later in this chapter.

More ➠
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Methods for working with groups

To Do this

Have a shape resize differently from the group To open the group window, select the group and then choose Open

Group from the Edit menu. Select the shape whose behavior you

want to control. From the Format menu, choose Behavior. Under

Resize Behavior, choose the behavior you want.

Rotate a group Rotate the group as you would any other shape. From the Shape

menu, choose Rotate Left or Rotate Right (or click the Rotate buttons

on the toolbar). Imported objects will not rotate with the group. For

details, see “Flipping and Rotating Shapes” later in this chapter.

Rotate an individual shape within a group To open the group window, select the group and then choose Open

Group from the Edit menu. Rotate the shape as you would any other

shape. Click the group window’s close box. For details about rotating,

see “Flipping and Rotating Shapes” later in this chapter.

Add a shape to a group Select the group. Press the Shift key and select the shape you want to

add. From the Shape menu, choose Grouping, then choose Add To

Group. You can also open the group window, then drag a shape from

the drawing page or a stencil into the group window.

Remove a shape from a group Select the group, then click the shape you want to remove to subselect

it. From the Shape menu, choose Grouping, then choose Remove

From Group. You can also remove a shape by dragging it out of the

group window.

More ➠
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Methods for working with groups

To Do this

Change the size of a group’s selection rectangle Select the group. From the Tools menu, choose Update Alignment

Box.

Add text to a group Select the group, then type. The text is added to the frontmost shape

in the group that can have text and that is itself not a group. Groups

can contain guides and objects from other applications, but text

won’t appear on these items.

Add text to a specific group shape Double-click the group to open the group window. Select the shape

to add text to, then type. Click the group window’s close box.

Make a particular shape the frontmost shape Select the group, then click the shape you want at the front to

subselect it. From the Shape menu, choose Bring To Front.

Assign a group to a layer Select the group. From the Format menu, choose Layer. In the Layer

box, choose the layer you want the group to belong to, then click OK.

If you want shapes within the group to retain their individual layer

membership, check Preserve Group Member Layers. For details about

layers, see Chapter 6, “Organizing Shapes with SmartLayers.”

Assign a shape in a group to a layer Select the group, then click the shape you want to assign to subselect

it. From the Format menu, choose Layer. In the Layer box, choose the

layer to which you want the shape to belong, then click OK. For

details about layers, see Chapter 6, “Organizing Shapes with

SmartLayers.”
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Q U I C K L Y  F O R M A T T I N G  S H A P E S

The quickest way to change a shape’s appearance is to use
toolbar buttons and Text, Line, or Fill style lists.

Toolbar buttons
By using the toolbar buttons you can quickly change:

• Line ends (such as arrowheads) on open shapes.

• Line patterns (solid, dashed), line weight, and line color on
open or closed shapes.

• Corners (to make them more or less rounded) on closed
shapes.

• Fill color and patterns on closed shapes.

• Shadow color on open and closed shapes.

• Text size, color, font, style, and alignment.

Style Lists
When you format shapes using the Text, Line, or Fill style lists,
you’re actually applying a style. Styles can contain line, fill, and
text formatting attributes. It’s best to use a style if you want to
apply many formatting attributes to many different shapes.
When you start a drawing with a Visio Technical template, the
template includes style definitions and the appropriate styles
appear in the style lists on the toolbar.

When a style includes two or more types of formatting at-
tributes (text and line, or text, line, and fill, for example) you
can choose whether all of the attributes are applied to selected
shapes. For example, if you choose Normal from the Fill style
list, Visio applies the Normal fill formatting attributes to the
selected shape. Then, if Normal has line attributes and text at-
tributes associated with it, Visio asks if you want to apply all
the associated attributes as well.

Tip: If you choose a style from one of the style lists when
no shapes are selected, that style becomes the default and is
applied to the next shape you draw.

Using the Format menu

You can also make formatting changes by choosing an
option from the Format menu. While it’s faster to use
the toolbar buttons and style lists, many additional
options are available in the dialog boxes that open
when you choose a Format menu option. To quickly
access the Format menu, right-click a selected shape.

When you select a shape and apply, for example,
a text style that also has line and fill properties,
a dialog box appears. Click Yes if you want to
apply all the attributes. Click No if you want to
apply only class of the attributes you originally
chose.

When you click a toolbar button to format a
selected shape, Visio cycles through various
options. For example, clicking the Shadow button
cycles through various shades of gray.
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Formatting multiple shapes
There are several ways to format multiple shapes quickly. The
Format Painter button quickly copies formatting from one
shape to another.

Methods for repeating or copying formatting

To Do This

Format several shapes at once Select all the shapes you want to format, then choose the formatting

buttons and style list options you want.

Quickly repeat one formatting change Make one formatting change to a shape. Select other shapes, then

press F4.

Copy one shape’s formatting to another shape Select the shape with the formatting you want to copy. Click the

Format Painter button, then click the shape you want to copy the

formatting to.

Copy only text attributes from one Double-click a shape to select the text. Click the Format Painter

shape to another button. Click the shape you want to copy the formatting to.

Copy one shape’s formatting to Select the shape with the formatting you want to copy. Double-click

other shapes sequentially the Format Painter button, then click the shapes you want to copy

formatting to.

Copy one shape’s formatting to several Select the shape with the formatting you want to copy, then press the

others simultaneously Shift key and select the shapes you want to copy formatting to. Click

the Format Painter button.

For details about styles, including how to edit them, see “Sav-
ing Time with Styles” in Chapter 4, “Saving Time and Reusing
Work,” and see Developing Visio Solutions. For details about
formatting text, see “Formatting Text” in Chapter 3, “Adding
Text to Drawings.”

When shapes have shadows

You can quickly assign a shadow to a selected shape
by clicking the Shadow button. You can format the
shape’s shadow by choosing Shadow from the Format
menu. Each shape on a page can have a unique
shadow in terms of color or pattern. Shadow offset,
however, is a page setting. Each shadow you add to a
shape on a page is offset the same direction and
amount. To set shadow offset for a page, choose
Drawing Page from the File menu, then choose Prop-
erties. In the Properties dialog box, under Shape
Shadow Offset, type the shadow offset amounts you
want. To position a shadow up or to the left, type
negative numbers in the Down and Right boxes.

Format Painter
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D U P L I C A T I N G  S H A P E S

You can duplicate shapes within the same drawing or between
drawings, or copy shapes from a Visio drawing into a docu-
ment created in another program. In Visio, you can place
shapes exactly where you want them in relation to one another
as you duplicate them. For example, you can easily design an
auditorium with dozens of rows of seats, or a steel structure
with regularly placed rivets. Visio also includes the Array
Shapes Add-on, with which you can duplicate shapes and then
change all copies by changing the original shape.

Methods for duplicating shapes

To Do this

Add several copies of a master From the connection tool menu on the toolbar, choose the stamp

to a drawing tool. Click a master on a stencil to select it, and then in the drawing

page window, click the pointer where you want the center of the

shape to appear. Continue clicking where you want to place addi-

tional copies of the shape.

Duplicate a shape within the same drawing Select the shape you want to duplicate. From the Edit menu, choose

Duplicate, or press Ctrl+D. The copy appears on the page slightly

offset from the original shape.

Duplicate a shape at a specific location Select the shape you want to duplicate. Hold down the Ctrl key and

drag to where you want the copy.

Repeatedly duplicate a shape and the offset Select the shape. Hold down the Ctrl key and drag to where you want

between copies the copy. Release the mouse button. Press F4 for each copy you

want.

Copy and paste shapes from a Visio Display the drawing page that contains the shape you want to copy.

drawing into another program that Display the document into which you want to copy the shape. Hold

supports OLE 2 down the Ctrl key and drag the shape from Visio into the other

document.

Copy and paste shapes from a Visio Select the shape you want to copy. From the Edit menu, choose Copy.

drawing into another program that In the document where you want to copy the shape, choose Paste

doesn’t support OLE 2 from the Edit menu.
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The Array Shapes Add-on is designed to help you create spe-
cifically-spaced rows and columns of shapes. To resize, rotate,
or flip duplicate shapes by simply resizing, rotating, or flipping
the original shape from which you constructed the array, check
Reference Primary Shape’s Size & Position.

To create an array:

1. Select the shape or the shapes you want to duplicate and
arrange.

2. From the Tools menu, choose Array Shapes. In the Array
Shapes dialog box, choose the options you want.

For details about aligning shapes, see “Arranging Shapes” later
in this chapter.

A

B

C

Array Shapes dialog box

A Choose the number of rows and columns in
which you want duplicated shapes.

B Choose the horizontal and vertical spacing
between shape centers or edges.

C Check to make the first shape you select control
the behavior of the duplicate shapes in the array.
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F L I P P I N G  A N D  R O T A T I N G  S H A P E S

You can change the direction shapes are facing by using the
Flip, Reverse, and Rotate commands and buttons, or by using
the rotation tool.  As you rotate shapes, information on the
status bar at the bottom of the Visio window displays the exact
angle of rotation.

Tip: For precise rotation, you can also use the Size &
Position command. For details, see “Precisely Sizing and
Positioning an Object” in Chapter 5, “Measuring and
Dimensioning.”

When you select a shape with the rotation tool, rotation handles appear in
the corners and a pin (center of rotation) appears in the center.

As the pointer moves over a rotation handle, the pointer changes to a round
arrow indicating that you can rotate the shape.

You can rotate a shape around any point by moving the shape’s pin to that
point.

Rotation tool

Horizontal

Vertical
Flipping shapes horizontally or vertically

Reverse ends
Reversing ends flips shapes both horizontally and
vertically.

Rotate Left and Rotate Right rotate a shape 90
degrees at a time. With the rotation tool, you can
rotate a shape to any angle.
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Methods for flipping and rotating shapes

To Use this tool Take these steps

Rotate a shape by 90 degrees Select the shape. From the Shape

menu, choose Rotate Left to rotate the shape

counterclockwise or Rotate Right to rotate the

shape clockwise. (Or, click the toolbar buttons.)

Rotate a shape by any amount Click the rotation tool on the toolbar, then click

the shape to select it. Drag a rotation handle.

For more control, drag the pointer farther from

the pin.

Move a shape’s pin Click the rotation tool on the toolbar, then click

the shape to select it. Drag the pin to its new

location.

Flip or reverse a shape Select the shape. From the Shape menu, choose

Flip Vertical, Flip Horizontal, or Reverse Ends.

(Or, click the toolbar buttons.)

Flip and rotate from the keyboard

To quickly flip and rotate shapes, select the shape,
and then use these keyboard shortcuts:

Rotate right Ctrl+R

Rotate left Ctrl+L

Flip vertical Ctrl+J

Flip horizontal Ctrl+H

What doesn’t rotate?

You cannot rotate imported metafiles and bitmaps.
Also, to rotate an individual shape relative to the
group it belongs to, you must first open the group
window. For details about working with groups, see
“Grouping Shapes” earlier in this chapter.



54 U S I N G   V I S I O   T E C H N I C A L

A R R A N G I N G  S H A P E S

You can align shapes by gluing them to a guide or a guide point
or by using the Align Shapes command. To create equal dis-
tances between shapes, you can create evenly spaced guides and
glue shapes to them, or use the Distribute Shapes command.
When shapes are glued to a guide, you can move the guide and
the aligned shapes with it.

To align shapes to a guide:

1. Drag a guide from a ruler onto the drawing page.

The guide appears as a blue line.

2. From the Tools menu, choose Snap & Glue to make sure
Glue is checked under Currently Active and Guides is
checked under Glue To.

3. Drag shapes to the locations on the guide where you want
to glue them.

Tip: You can automatically create a guide and glue shapes
to it using the Align Shapes command. Simply check
Create Guide And Glue Shapes To It in the Align Shapes
dialog box.

To align points on shapes to a guide point:

1. Point to the crossbar at the intersection of the two rulers,
then drag to where you want the guide point.

The guide point appears as two blue crossed lines.

2. Position shapes you want to align with their centers or
selection handles (for 2-D shapes) or endpoints (for 1-D
shapes) on the guide point.

Guide details

This section mentions guides, but there’s more you
should know about them. For some illustrations of
how you can use guides, see “Moving Several Aligned
Shapes at Once” later in this chapter. For details
about setting up guides, see “Setting Up Guides” in
Chapter 5, “Measuring and Dimensioning.”
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To align shapes using the Align Shapes command:

1. Select the shape you want to align other shapes to.

2. Hold down the Shift key and select subsequent shapes.

3. From the Tools menu, choose Align Shapes. In the dialog
box, choose the align options you want, then click OK.

Tip: You can also align shapes by using the Align Shapes
buttons on the toolbar.

Alignment options

To align these shapes This way Select Choose this alignment option

Shape A first Top align

Shape B first Horizontal align

Shape C first Bottom align

Shape A first Left align

Shape B first Vertical align

Shape C first Right align

A
B C

A
B

C

A B C

A
B C

A

B

C

A

B

C

A

B

C

A
B

C

A
B

C

A

B

C

A

B

C

A

B

C

Align Shapes
buttons
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To distribute shapes using evenly spaced guides:

1. Drag the first guide from the appropriate ruler.

2. To create the second guide, hold down the Ctrl key and
drag from the first guide to where you want the second
guide.

3. To create subsequent guides, press F4 for each additional
guide you want.

4. Glue shapes to the guides so they’re distributed the way
you want.

Tip: You can automatically create multiple guides with
shapes glued to them using the Distribute Shapes com-
mand. Simply check Create Guides And Glue Objects To
Them in the Distribute Shapes dialog box.

To distribute shapes using the Distribute Shapes command:

1. Select three or more shapes you want to distribute.

2. From the Tools menu, choose Distribute Shapes.

3. In the Distribute Shapes dialog box, choose the distribute
option you want.

Tip: You can also distribute shapes using the Distribute
Shapes buttons on the toolbar.

Distribute Shapes buttons
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Distribution options

To align these shapes This way Choose this alignment option

Horizontal ends distribution

Left distribution

Horizontal center distribution

Right distribution

Vertical ends distribution

Top distribution

Vertical center distribution

Bottom distribution
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M O V I N G  S E V E R A L  A L I G N E D  S H A P E S  A T  O N C E

To move several related shapes while keeping them aligned,
glue the shapes to a guide, then move the guide as necessary.
You may want to group some shapes first, so that even shapes
that don’t actually touch the guide move with it.

When shapes are glued to a guide, you can move the guide to make several
adjustments to the drawing at once.

Guide
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Consequat

Sed diam

Dignissim

Hendrerit in vulputate

Praesent

As you move the vertical guide, the switches glued to it move with it and stay
correctly aligned and spaced.

To use a guide to move several related shapes:

1. From the Tools menu, choose Snap & Glue, and in the
dialog box, make sure Guides is checked in the Snap To and
Glue To lists.

2. Create the part of the drawing that includes the shapes you
may need to move. Group shapes as necessary.

3. Drag a guide from the appropriate ruler and glue shapes to
the guide.

Shapes’ endpoints and selection handles turn red when
they’re glued.

4. Drag the guide to the shape’s new location.

Guide

By setting up a series of evenly spaced guides, you
can distribute shapes in a drawing. To measure
the distance between guides, use a dimension line.

Tation

Duis autem

Blandit praesent

Aliquam

1 
19

/2
1 

cm



60 U S I N G   V I S I O   T E C H N I C A L

D R A W I N G  S H A P E S

Even though Visio supplies thousands of shapes, there may be
times you’ll need to draw your own shapes.

To draw a shape, use one or more of the tools shown in the fol-
lowing illustrations. You can also create new and complex
shapes by merging and grouping shapes. For details, see “Merg-
ing Shapes to Create New Ones” and “Grouping Shapes” in this
chapter. For details about editing shapes, see “Revising Indi-
vidual Shapes” later in this chapter.

Draw both lines and arcs with the pencil tool. If you move the
pencil in a straight line, it draws a line. If you move it in a
curve, it draws an arc. Each arc is a portion of a circle; its size is
determined by the distance you move the mouse.

The line tool is the best tool for drawing shapes composed only
of straight lines. To constrain a line to 45-degree intervals, hold
down the Shift key as you draw.

The arc tool draws arcs that are always one-quarter of an el-
lipse. The direction you drag the mouse determines which way
the arc bows.

The freeform tool works like a pencil on paper. Select it and
drag to draw freeform curves. For smoother curves, turn snap-
ping off before you draw. (From the Tool menu, choose Snap &
Glue, then, under Currently Active, uncheck Snap).

The rectangle tool draws rectangles, including squares. To draw
a square, hold down the Shift key as you drag.

The ellipse tool draws ellipses, including circles. To draw a
circle, hold down the Shift key as you drag.

The drawing tools.
To draw, choose
the appropriate tool,
then drag.

Pencil tool

Line tool

Arc tool

Freeform tool

Rectangle tool

Ellipse tool
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Endpoints

Vertices

Control points

To draw a shape with multiple segments:

1. To draw the first segment, choose the appropriate drawing
tool, and then point to where you want to start the shape.
Drag until the segment is the size you want, then release
the mouse button.

This first segment is a 1-D shape with endpoints.

2. To draw the second segment, point to an endpoint, drag,
and then release the mouse button.

When you begin to draw the second and subsequent
segments, be careful not to select the endpoint where you
want to start the segment. A selected endpoint turns
magenta, and dragging it resizes the existing segment
rather than starts a new segment.

After you add a second segment, the shape becomes two-
dimensional and has vertices at the ends of segments, not
endpoints.

3. To draw subsquent segments, repeat step 2 for each
segment.

To close a shape, drag until the crossbar of the pointer is
over the vertex at the beginning of the first segment of the
shape.

Tip: A shape drawn with the freeform and ellipse tools can
be a closed shape composed of one segment.

To undo a segment while drawing:

1. Before you release the mouse button at the end of a
segment, drag back to the vertex at the beginning of the
segment. Make sure you hit the vertex precisely or you
might not completely delete the segment.

To undo several segments:

1. After you’ve drawn several segments but before you do
anything else, choose Undo from the Edit menu. Keep
choosing Undo until you’ve deleted all the segments you
no longer want. Segments are deleted in the reverse of the
order in which they were drawn.

Quick undos

To quickly undo segments you’ve drawn or to undo
other actions you’ve taken in Visio, press Ctrl+Z or
Alt+Backspace. By default, you can undo up to ten
actions.
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M E R G I N G  S H A P E S  T O  C R E A T E  N E W  O N E S

One of the easiest ways to create a complex shape is to draw its
simple parts, then use one of Visio’s Boolean operation com-
mands to merge the parts into one complex shape. These
commands include: Union, Subtract, Intersect, Fit Curve, Cus-
tom Fit, Fragment, Trim, Join, and Combine.

The result of a merge operation depends partly on which shape
you select first. The primary shape’s formatting is used in the
resulting shape, and in some cases, it even determines the
shape of that new shape (with the Subtract command, for ex-
ample). In the following illustrations, the darker shape is the
primary shape.

Merging operations create new shapes. That means that the
old shapes, including their ShapeSheets which might define
smart behavior, are discarded. The new shape gets its own
ShapeSheet.

Union creates a shape that is a set of all the points that were ei-
ther in one original shape or another. Union is the equivalent
of the boolean operator “OR.”

Subtract is explained by: A–B = all of A not in B. The primary
shape (A) is like a stock and the other shape (B) is like a tool.
The tool indicates the area you want to remove from the stock.
After you Subtract the shapes, the tool is deleted.

Intersect forms a new shape from the areas where selected
shapes overlap, and it eliminates non-overlapping areas. Since
Visio doesn’t define specific points on a line, nothing is left if
you intersect two overlapping lines.

Fit Curve fits a spline to a polygon’s set of vertices.

Custom Fit does the same thing as Fit Curve, except that you
can set the approximation error tolerance, and whether or not
to set curve fitting options for periodic splines, circular arcs,
and cusps and bumps.

Subtract

Intersect

Fit Curve

Union

A

B

Original

Result

Tolerance=10 mm

Tolerance=20 mm
Custom Fit



M O R E   A B O U T   S H A P E S 63

Visio’s merge operations and CorelDraw!

In CorelDraw, the last shape selected is the primary
shape—the one that determines how the new merged
shape will be formatted. In Visio, the first shape se-
lected is primary.

Fragment

Trim

Fragment creates all possible regions from selected lines and
curves. Everything outside the regions is eliminated.

Trim resembles the trim operation in AutoCAD, although in
Visio you can trim more than two objects. Trim splits selected
objects at their intersections, including where a shape inter-
sects itself. It creates a new shape for each piece, preserving
styles. Shapes that are split open lose their fill.

Join creates one shape from shapes that are touching at their
ends. Join assembles segments into paths. (A path is a continu-
ous series of segments.) The number of paths depends upon
the configuration of the selected shapes. If the shapes lie along
a straight line, for example, the new shape will have one path.

Combine puts the Geometry sections on the ShapeSheets of
selected shapes into one shape. If the selected shapes overlap,
Combine cuts a hole the size of the overlap, which creates one
shape with more than one path. Combine is a simple opera-
tion. Its effects can all be achieved by using other, more
complex merging operations.

To merge shapes:

1. Select the shapes you want to merge.

The primary selection determines the formatting of the
merged shape.

2. From the Shape menu, choose Operations, then choose the
particular merging command you want.

Join

Combine

Visio’s merge operations and AutoCAD

If you’re an AutoCAD user, some of Visio’s merge op-
erations, such as Trim, will seem familiar, but you’ll
need to think a little differently about how to perform
an operation. In AutoCAD, the order for performing
operations is command or operation first, then objects.
In Visio, however, you choose the objects (that is, the
shapes) first, and then the operation (that is, the com-
mand). Also, in Visio you can perform an operation on
more than two shapes.

Path 1

Path 2



64 U S I N G   V I S I O   T E C H N I C A L

R E V I S I N G  I N D I V I D U A L  S H A P E S

Even as you draw a shape, you’ll want to use these techniques
for revising shapes. At any time, you can revise any Visio Tech-
nical shape or any shape you create, as long as the shape hasn’t
been protected with locks against specific changes.

The main way you revise a shape is by selecting the shape with
the pencil tool and dragging, adding, or deleting vertices. To
change curves, you drag control points or their eccentricity
handles. For details about the handles on shapes and what they
are used for, see “Shape Anatomy” earlier in this chapter.

Revising groups

If you select a shape with the pencil tool and don’t
see any vertices or control handles, the shape is a
group. To revise the group, select it, then choose Open
Group from the Edit menu. A group window opens in
which you can revise the shape using the pencil tool.

Delete vertex A

A B

C

A

Delete vertex A Delete vertex B Delete vertex C

AAB

C C

B

Deleting a vertex deletes the segment with which the vertex is associated.

To reshape a shape, you can drag a vertex...

...add and then drag a vertex...

...or drag control points to edit curves.
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Methods for editing shapes

To Select the shape and use the pencil tool to

Select a vertex or control point Click the vertex or control point you want to select. The selected item

turns magenta.

Move shape vertices Select one or more vertices and drag. Hold down the Shift key to

select more than one.

Add a vertex Point to where you want to add a vertex, hold down the Ctrl key,

and click.

Delete a segment Select a vertex associated with the segment you want to delete, then

press the Delete key.

Change the curvature of an Drag a control point until the segment looks the way you want.

arc or freeform curve

Change the symmetry of an arc Select a control point, then hold down the Ctrl key, and drag the

pointer slightly away from the point to display two handles, and then

release the mouse button. Drag one handle farther or closer to the

control point or rotate it around the control point until the arc is

aligned the way you want.

Move the end of a freeform curve Select the curve, then drag a handle associated with the curve’s

endpoint.

For details about editing master shapes, search online Help for
“master shapes.”
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Adding Text to Drawings

Technical drawings often include text such as title blocks, la-
bels, legends, or data fields that display page numbers and
other information. You can easily add text to any shape or cre-
ate a text-only shape anywhere on the drawing page. In
addition, you can add data fields that automatically display and
update information, such as dates, times, and page numbers.

This chapter describes how to type, edit, and format text. It
also describes how to set tabs so you can create tables or
bulleted lists, and how to check spelling or search for and re-
place text.

Topics in this chapter

Text Anatomy ............................................................................ 68

Editing Text ............................................................................... 70

Working with Text Blocks ........................................................ 71

Formatting Text ........................................................................ 72

Setting Tabs ............................................................................... 74

Checking Spelling and Replacing Text ..................................... 76

Adding Page Numbers and Other Data Fields ........................ 80
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eros et
accumsan

exerci tation

T E X T  A N A T O M Y

In Visio Technical, you can add text to any shape. You can also
create text-only shapes to add titles, lists, and so on to a draw-
ing. In a text-only shape, the shape has no line or fill, so only
the text is visible. The part of a shape where you type text is the
text block. A shape and its text block can differ in size, angle,
and location, so that you can place text where you need it in re-
lation to a shape.

You can add text to most shapes simply by selecting the shape
and typing. Visio opens the text block and displays the inser-
tion point, the vertical cursor that shows where the next thing
you type will appear. You can move the insertion point by
clicking anywhere in the text block or in another shape. Click
outside the shape or press the Esc key when you’re finished
typing.

You can use the text tool and text block tool for finer control
over text.  Select a shape with the text tool to open its text block
and highlight the contents. Select a shape with the text block
tool to select only the text block.

For details about working with the text tools, see the following
sections.

Zooming in on text

When you click text with the text tool or double-click
a shape with the pointer tool, Visio Technical zooms in
to give you a closer look at the text you’re typing or
editing. To return to the original magnification, press
the Esc key or click anywhere outside the shape or
text block.

eros et
accumsan

You can rotate, move, and resize a text block
independently of the shape containing it.

The text block determines the location of text
when you type in a shape.

You can add text to
any 2-D shape…

…or 1-D shape.

Text tool

Text block tool
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About formatting text
When you type in an instance of a master, the text format-
ting—font, size, color, and so on—is determined by the styles
used for the master. When you type in a shape you create your-
self, the text is formatted according to the default text style in
use for the drawing page. You can change the font, size, color,
style, spacing, indent, and alignment for any text that appears
in a Visio drawing.

For details about formatting text, see “Formatting Text” later in
this chapter.

Working with text in groups
Only individual shapes have text blocks; groups do not. When
you select a group and then type, you’re really typing in the
frontmost shape in the group. For example, the Multimedia PC
shape is a group consisting of computer components and a
text-only shape as the frontmost shape. If you select the group
and then type, you change the text of the text-only shape.
However, you can also subselect the monitor to type a message
on its screen.

Many Visio masters are groups that contain a text-only shape.
They are designed so that text appears at a very specific
location. If you create a group and then type in it, the text
appears by default in the the shape frontmost in the stacking
order, but you can edit the group to change the stacking order
of the shapes, and thereby change which shape you type in.
If you want, you can include a text-only shape in the groups
you create.

et accumsan
et iusto odio
dignissim

et accumsan
et iusto odio
dignissim

Double-click a shape to select the text for editing.

Duis autem vel
eum iriure dolor
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When you resize a shape, its text block also
resizes. To change font size, however, use the Font
size list on the toolbar.
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SmartShapes format and position the text block to
suit the shape’s purpose.

Text in title blocks

Most technical drawings include text in a title block
that identifies the author, version number, and so on.
Visio includes masters that make it easy to create a
title block that conforms to your company’s standards.

For details, see “Adding a Title Block” in Chapter 7,
“Sharing Drawings.”
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E D I T I N G  T E X T

To add, edit, or format text, you can select part or all of the text
in a shape’s text block. You can also copy, cut, and paste text in
much the same way as any word-processing program. To repeat
a text action, such as pasting text, press the F4 key.

For details about keyboard shortcuts for moving the insertion
point, search online Help for “insertion point.”

Methods for adding and editing text

To Use this tool Take these steps

Add text to a shape The pointer tool, or Select the shape, then type. If the shape already

any tool on the drawing has text, the text you type replaces it. When you

tools menus finish typing, click outside the shape or press Esc.

Create a text-only shape Click where you want to start typing. Or, drag to

(such as for a title) outline the size of the text block, then type.

Place the insertion point Click the shape or triple-click a shape with the

in text pointer tool.

Select all text and Double-click the shape. Or select the shape, then

display the insertion point press F2.

Select a sentence or Click the shape, then drag the insertion point.

character

Select a word or Click the shape, then double-click a word or

paragraph triple-click a paragraph.

Cut or copy selected Select the text you want as above, then press

text to the Clipboard Ctrl+X to cut or Ctrl+C to copy.

Copy all text to Click the shape, then press Ctrl+C.

the Clipboard

Paste text from the Click to place the insertion point, then press

Clipboard Ctrl+V.
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W O R K I N G  W I T H  T E X T  B L O C K S

You can change where text appears on a shape by moving or
resizing the text block. For many SmartShapes, the default size
and position of the text block differs from the shape itself. For
example, in the Rotary Pump shape, text appears beneath the
shape. Visio masters often include a control handle that you
can use to reposition the text block, but if you draw your own
shapes or want to change the text block size, you can edit a text
block manually.

By using the text block tool, you can select text blocks, move
them, and drag their selection handles to resize and rotate
them.

Tip: To automate the process of editing a shape’s text block,
use the SmartShape Wizard. It can customize the size and
position of a text block. You can run the SmartShape
Wizard from the Run Add-On submenu of the Tools menu.

Methods for working with text blocks

To Use this tool Take these steps

Change text block size Click the shape, then drag one of the square

selection handles.

Move a text block Click the shape, then place the pointer over it.

The pointer turns into a white rectangle. Drag the

text block where you want it.

Rotate a text block Click the shape, place the pointer over a round

selection handle, then drag in the direction

you want the text block to rotate.

Select a text block in a group Click the group, then choose Open <name> from

to work with  the Edit menu. With the text block tool, select a

shape whose text block you want to change.

To display the selection and rotation handles for a
text block, select a shape with the text block tool.

Typing special characters

To type special characters from the ANSI extended
character set, press the Alt key, then type a combina-
tion of number keys on the keypad. For example, to
type the degree symbol (°), press Alt+0176 on the
numeric keypad.

For a list of the ANSI codes or special characters,
search online Help for “ansi” or “special.”
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F O R M A T T I N G  T E X T

When you format text, you choose attributes, such as align-
ment or color, for the text block as well as the text itself. You
can format entire text blocks as well as individual paragraphs,
words, or characters. To quickly format text, you can use
toolbar style lists and formatting buttons. For more extensive
formatting, choose a command from the Format menu.
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When text is selected, these text styles and formatting buttons are available
on the toolbar.

Choose Font from the Format menu to change the font, size, color, and other
attributes of selected text.

Font dialog box

A Choose font, size, color, and case.

B Choose a normal, superscript, or subscript
position.

C Click to open other text formatting dialog
boxes.

D Click to format the shape’s fill and line.

Choose Paragraph from the Format menu to change the horizontal alignment,
indents, and spacing of text.

Paragraph dialog box

A Choose the alignment of text lines.

B Set indents between paragraphs and the edge
of the text block.

C Set spacing as a percentage of font size, or as
an absolute amount, such as 12 point (pt).

D Click to open the Font dialog box.

DB

C

A

D
C

A

B
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Choose Text Block from the Format menu to change the vertical alignment,
margins, or background color of the text.

The table below summarizes formatting options for text. For
details about selecting the portion of text you want to format,
see the previous section. For details about other formatting op-
tions, search online Help for “formatting text.”

Methods of formatting text

To Do this

Format an entire text block Place the insertion point in a shape, then choose the formatting options you

want from the toolbar or Format menu.

Format individual paragraphs, Select the text you want to format, then choose the formatting options you

words, or characters want.

Add a colored background to text Select the shape, then choose Text Block from the Format menu. Click Solid

Color, then choose a color.

Set horizontal alignment and Select the paragraph or text block you want to format. From the Format menu,

line spacing choose Paragraph. In the Paragraph dialog box, choose the options you want.

Set margins and vertical alignment Select the text block you want to format. From the Format menu, choose Text

Block. In the Text Block dialog box, choose the options you want.

Text Block dialog box

A Choose the vertical alignment of text within
the text block.

B Set the margins between text and the edges
of the text block selection rectangle.

C Click for no text background color.

D Click to add a colored background behind
the text, then choose a color from the list.
The color fills only the area around the text,
not the text block.

E Click to open the Font dialog box.

Using text styles

To consistently format the text for many shapes, or
apply several attributes to multiple shapes, it’s best to
apply a style or create a new one.

For details, see Chapter 4, “Saving Time and Reusing
Work.”

E

A

B

C
D
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S E T T I N G  T A B S

You can set tabs to align text in table form or to create bullet
lists. A text block can have up to ten tab stops.

Tab positions are based on the width of the text block, not the
width of the shape or the shape’s distance from the edges of the
page. Setting tabs is easier if you move the zero point to the
edge of the text block before you choose tab positions.

In Visio Technical, tabs can be left-, center-, or right-aligned.
You can also use decimal tabs to align columns of numbers.

Lorem 01 31 22
Ipsum 22 03 09

Select a text block to set tabs for the whole text
block at once.

Duis autem vel:
Eros Dolor Odio

Select specific text to set tabs for part of a text
block.

 Left Center Right Decimal
29.95 29.95 29.95 29.95
4.630 4.630 4.630 4.630
134.29 134.29 134.29 134.29
.250 .250 .250 .250

Examples of tabs you set in Visio Technical.

• Lorem Ipsum dolor sit amet

• Consectetuer adipiscing elit

• Sed diam nonummy nibh euismod

Tincidunt ut laorett dolore magna

• Aliquam erat volutpat Ut wisi enim ad nimim

By using tabs in combination with paragraph indent settings, you can create
bulleted lists with hanging indents.

D

E

C

A

B

You can set tab positions and alignment for selected text with the Tabs
command on the Format menu.

Tabs dialog box

A Choose the tab stop to insert into the selected text.

B Create a new tab stop to add to the list. Type the
position from the edge of the text block, choose the
tab alignment, then click Add.

C Click to delete the tab stop selected in the list.

D Click to open the Font dialog box if you want to
change the way selected text looks.

E Click to apply the tab settings and close the dialog
box.
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To create a bullet list:

1. Choose the text tool and draw a text block or select an
existing text block or shape.

2. From the Format menu, choose Paragraph. In the Para-
graph dialog box, under Horizontal Alignment, choose
Left.

3. In the From Left box, type a value that leaves enough room
for a bullet and a blank space. For example, type 1 pica.

4. In the First Line box, type a negative value (for example, –1
pica), then click OK.

5. From the Format menu, choose Tabs.

6. In the Tabs dialog box, under Position, type the same value
you used in step 3. Click Add, then click OK.

7. To create a list item, type a bullet character, press Tab, then
type text.

To set tabs for table text:

1. With the text tool, draw a text block or select an existing
one.

2. From the Format menu, choose Paragraph. In the Para-
graph dialog box, set Horizontal Alignment to Left and
Indents to zero, then click OK.

3. Move the vertical ruler’s zero point to the left edge of the
text block. To do this, hold down the Ctrl key and drag
from the vertical ruler.

4. From the Format menu, choose Tabs. Drag the Tabs dialog
box so you can see the text block.

5. Enter each tab position and alignment, clicking Add after
each one.

Because you moved the zero point, you can set tab stops as
the distance from zero.

6. Click OK.

• • • • • •To insert a bullet character, type Ctrl+Shift+8.
Select the bullet and use the Font Size list on the
toolbar to change its size.
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C H E C K I N G  S P E L L I N G  A N D  R E P L A C I N G  T E X T

You can check the spelling of text in a drawing, as well as search
for text or replace specified text with a selection. When you
check the spelling of or search for text, Visio searches in all
shapes, including text-only shapes, data fields, and stencils. It
also checks text you enter in the Properties dialog box. You can
specify whether Visio searches an entire drawing, a particular
page, or selected text only.

If you use industry or company words that aren’t in a standard
dictionary, you can create a user dictionary that includes these
words. Then, when Visio checks your spelling, it won’t identify
these words as misspelled. You can even create different user
dictionaries for different purposes and make them active or in-
active when you’re checking spelling for certain drawings.

When you choose Spelling from the Tools menu, the Spelling dialog box opens
only if Visio Technical encounters words not found in its dictionary.

Spelling dialog box

A Displays a word not found in the open dic-
tionary.

B Type or select a word from the Suggestions
list to replace the misspelled word.

C Lists alternative spellings from the open dic-
tionary.

D Select the user dictionary to which you want
to add the new word.

E Ignores the word and continues checking.

F Changes the word to the one in the Change
To box.

G Adds the word to the dictionary selected in
the Add Words To box.

H Ignores all instances of the word encountered
in the Visio drawing.

I Changes all instances of the word to the one
in the Change To box.

J Displays the Spelling Options dialog box, in
which you can specify default settings for the
Spelling command.

K Closes the dialog box but does not cancel
any changes you’ve made.
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You can set default options for how Visio Technical checks spelling in a
drawing.

To check spelling in a drawing:

1. Choose Spelling from the Tools menu, check the Spelling
button on the toolbar, or press F7.

2. If the Spelling dialog box appears, click the options you
want.

3. When Visio has finished checking the spelling, a message
box appears. Click OK.

Tip: To set spelling checker defaults, from the Tools menu,
choose Options, then click Spelling. In the Spelling
Options dialog box, choose the options you want.

Spelling Options dialog box

A Check the portion of a drawing you want to
search.

B Lists the active user dictionaries that will ap-
pear in the Add Word To list in the Spelling
dialog box.

C Click to create a new user dictionary and
add it to the active list or to add an existing
inactive user dictionary to the active list.

D Click to remove a dictionary from the active
list. Removing a user dictionary doesn’t de-
lete the file. You can make it active again at
another time.

E If you have Microsoft Word installed, check
this option to use its dictionary.

F Check this option if you want the spelling
checker to ignore words with numbers in
them.

C
E
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F
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To create a user dictionary:

1. From the Tools menu, choose Options. In the Options
dialog box, click Spelling.

2. In the Spelling Options dialog box, under User Diction-
aries, click Add.

3. In the Add User Dictionary dialog box, under File name,
type a name for the dictionary, then click Open.

4. In the Spelling Options dialog box, click OK.

To make a user dictionary inactive:

1. From the Tools menu, choose Options. In the Options
dialog box, click Spelling.

2. In the Spelling Options dialog box, under User Dictionar-
ies, choose the dictionary you want to remove, then click
Remove.

3. Click OK.

To search for a word or phrase:

1. From the Edit menu, choose Find.

2. In the Find dialog box, type the word or phrase you want
to find, or click special and choose a special character.

3. Choose the Search and Match options you want, then click
Find Next.

4. Close the Find dialog box to edit the word or phrase, or
click Find Next to find its next occurrence.

Making an inactive dictionary active

Removing a user dictionary from the Active list in the
Spelling Options dialog box doesn’t delete the user
dictionary. It just prevents the dictionary from
appearing in the Add Word To list in the Spelling
dialog box, making it impossible for you to add words
to it (while checking spelling). You can reactivate an
existing user dictionary by clicking Add in the Spelling
Options dialog box, locating the user dictionary in the
Add User Dictionary dialog box, then clicking Open.
By default, Visio Technical saves user dictionaries you
create in one of two places. If you’re using the Visio
dictionary, user dictionaries are stored in Visio’s
\System\Spelling folder. If you’re using the Microsoft
Word dictionary, user dictionaries are stored in the
Programs\Common\Proof folder.
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To replace a word or phrase:

1. From the Edit menu, choose Replace.

2. In the Replace dialog box, type the word or phrase you
want to replace, or click Special and choose a special
character.

3. Choose the Search and Match options you want, then click
Find Next or Replace All.

4. When Visio Technical has finished replacing text, a message
box appears. Click OK, then click Close to close the
Replace dialog box.

You can search for and replace special characters, choose which portions of a
drawing to search, and limit a search to whole words or word that match
upper- and lowercase.

Note:  In the worldwide English version of Visio Technical, you
can also specify whether you want to search for double-wide
characters, single-wide characters, or both.

Replace dialog box

A Type the word or phrase you want to find or
replace.

B Type the text you want to replace the search
word or phrase with.

C Click to search for or replace a special character
such as a tab or manual return.

D Click the portion of the drawing you want to
search.

E Click to locate only text that matches the case of
the search word or phrase.

F Click to locate only whole words that match the
search word or phrase.

G Click to replace all occurrences of a word or
phrase.

H Click to find the next occurrence of a word or
phrase, then click Replace to replace it.
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A D D I N G  P A G E  N U M B E R S
A N D  O T H E R  D A T A  F I E L D S

You can automate the display of some types of information by
creating a text field. For example, you can add page numbers
that Visio updates automatically. You can insert a text field into
any shape, then choose the type of information to appear, such
as date or time.

Use fields to display:

• Versions of a drawing by including a date/time field.

• Shape ID numbers and names, to help you verify com-
pleteness or inventory a drawing.

• Shape geometry, such as height, width, and angle of
rotation.

• The result of a calculation or any ShapeSheet cell’s result;
for example, the area of a shape.

• Information read from a field in a Lotus Notes database
into a Visio Technical drawing.

In general, to add a field, you place the insertion point in a text
block, then choose Field or Lotus Notes Field from the Insert
menu. The following table lists the fields you can add to text.
Procedures for adding some specific field types follow the
table.

You can format the text in fields the way you format any other
Visio Technical text. For details about formatting text, see
“Formatting Text” earlier in this chapter.

For details about displaying shape size, see “Using Dimension
Lines to Show Size” in Chapter 5, “Measuring and Dimension-
ing.”

For more details about Lotus Notes and Custom Formula
fields, search online Help for “lotus notes” or “custom for-
mula.”
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You can add a date/time text field to a drawing
to track versions automatically.

You can display shape geometry in a text field,
such as angle of rotation.
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Data fields you can add to drawings

Field Use to display

Date/Time Date and time a file was created, revised, or printed, or the current date and time.

Visio uses the date and time set in the Windows Control Panel.

Geometry Width, height, and angle information. Use to update technical specifications in a

drawing, create dimension lines, or measure the angle of rotation.

Document Info Information such as creator name, filename, subject, key words, and description

that are entered in the Properties dialog box for a file. To display the Properties dialog

box, choose Properties from the File menu.

Object Info Information such as shape name, ID number, and data, that are entered in the Special

dialog box. To display the Special dialog box, choose Special from the Format menu.

Page Info Information about a drawing page. Some of the information, such as drawing page

and background name, comes from the Page Properties dialog box. Use the Page

Number field to include page numbers in a drawing.

Lotus Notes Information from Lotus Notes in Visio Technical or information from Visio Technical

in Lotus Notes.

Custom Formula The result of a calculation you define by entering a formula. Formula syntax is the

same as the syntax used for ShapeSheet formulas or a reference to any cell’s result. For

details, search online Help for “syntax.”
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To display page numbers automatically:

1. Place the insertion point in a shape, or use the text block
tool to create a new text-only shape.

2. From the Insert menu, choose Field.

3. In the Field box, under Category, choose Page Info.

4. Under Field, choose Page Number, then click OK.

Tip: To have page numbers appear on every page in a mul-
tiple page drawing, copy and paste the field onto each page.
Or, place the field on a background, then assign the back-
ground to each drawing page.

To display a file’s date of creation automatically:

1. Place the insertion point in a shape, or use the text block
tool to create a new text-only shape.

2. From the Insert menu, choose Field.

3. In the Field dialog box, under Category, choose Date/Time.

4. Under Field, choose Creation Date. Under Format, choose
the format you want, then click OK.

To display the filename automatically:

1. Place the insertion point in a shape, or use the text block
tool to create a new text-only shape.

2. From the Insert menu, choose Field.

3. In the Field dialog box, under Category, choose Document
Info.

4. Under Field, choose Filename. Under Format, choose the
format you want, then click OK.
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Saving Time
and Reusing Work

Many drawings need to be revised constantly, and often, the
work you do on one project is useful on others. This chapter
explains some key ways you can save time and reuse work you
have already done.

Topics in this chapter

Revising Several Identical Shapes at Once ............................... 84

Saving Time with Styles ............................................................ 86

Creating New Stencils ............................................................... 90

Creating New Templates ........................................................... 92
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R E V I S I N G  S E V E R A L
I D E N T I C A L  S H A P E S  A T  O N C E

Whenever you create a drawing, Visio Technical creates a sten-
cil specific to that drawing file. This local stencil automatically
includes all masters that you used in the drawing file, regardless
of which stencil you originally dragged them from. You can
quickly revise all instances of a shape on all pages in a drawing
file by revising the master on the local stencil.

You can also add shapes you draw to the local stencil. Not only
does this make revising instances of those shapes easier, it also
makes it easy to quickly reuse a shape by dragging and drop-
ping it from the local stencil. If you plan to add a shape you
draw to the local stencil, it’s best to do so before duplicating
and copying the shape. Otherwise, revising the shape on the
stencil won’t revise copies of the shape that were on the page
before you added the shape to the local stencil.

To open a local stencil:

1. From the Window menu, choose Show Master Shape.

To add a shape you create to the local stencil:

1. Open the local stencil.

To arrange the windows, choose Tile from the Window
menu.

2. Drag the shape from the drawing page onto the local
stencil.

The shape is deleted from the drawing page. You then
replace it with an instance of the master in the next step. (If
you don’t want to delete the original shape, press Ctrl while
you drag the shape onto the stencil.)

3. Drag an instance of the new master back to the drawing
page to replace the shape you dragged to the local stencil.

4. With the local stencil window selected, choose Save from
the File menu to save the local stencil.

After you add a shape that you created to the
local stencil, you should replace the shape on the
drawing page with an instance of this new master.
Then, if you modify the master, you’ll automati-
cally update the shape on the drawing page.
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To revise a master on the local stencil and all instances of it:

1. Open the local stencil.

2. Double-click the master you want to revise.

3. In the new drawing window that contains the master
shape, revise the master. When you’re finished revising,
close the drawing window by clicking the close box. When
Visio asks if you want to update the master and its in-
stances, click Yes.

4. From the File menu, choose Save to save the local stencil.

The Visio window with the local stencil, a standalone stencil, and the drawing
window

For details about creating a standalone stencil from a local
stencil, see “Creating New Stencils” later in this chapter.
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S A V I N G  T I M E  W I T H  S T Y L E S

A style is a combination of fill, line, and text attributes, such as
red fill, 10-point line, and Arial 12-point italic text, that you
can apply to shapes. You can format a shape by manually ap-
plying each attribute, one at a time. However, it’s more efficient
to apply a style containing all those attributes to all the shapes
you want to format consistently. Moreover, simply by editing
the style, you can simultaneously change the look of all shapes
formatted with that style.

Visio templates come with styles built in, and many of these
styles include formatting for several attributes. This means you
can quickly format fill, lines, and text at once. For example, the
space planning templates include a style called Spaceplan.
When you apply all the attributes in Spaceplan to a shape, the
shape has a white fill, a 1-point black line, and centered, Arial,
8-point, black text.

Select three shapes and apply one style to make
them look the same.

The styles associated with a template or drawing
file appear on the toolbar in style lists, such as
the Fill style list shown here.

1 2 3

1 2 3
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Applying styles
When you choose a style from a toolbar list, Visio may ask if
you also want to apply all the formatting defined for the style,
or just the formatting for the attribute whose style list you
used. That way, you can choose a style from one list, such as
Text, that includes other attributes, but apply only the text at-
tributes.

When you choose a style from one of the toolbar lists, the style may format
other attributes as well, which you can choose whether or not to apply.

To apply a style:

1. Select one or more shapes.

2. From the Text, Line, or Fill style list, choose the style you
want to apply.

3. In the box, click Yes to apply all the attributes. Click No to
apply only one attribute.
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Editing and defining styles
You can edit and rename existing styles, create your own from
scratch, and delete styles you no longer need. To create or edit a
style, use the Define Styles command on the Format menu. In
the Style dialog box, you can choose which attributes to in-
clude in a style and how those attributes should be formatted.

1

2

3

1

2

3

When you edit a style, all shapes formatted with that style are reformatted.

To edit a style:

1. From the Format menu, choose Define Styles.

2. In the Define Styles dialog box, from the Style list, choose
the style you want to edit.

3. To rename the style, click Rename, type a new name for the
style, then click OK.

4. Under Change, click the attribute you want to edit. When
you finish editing the attributes, click the Change button.

Tip: To delete a style, in the Define Styles dialog box,
choose the name of the style you want to delete, click
Delete, then click OK.

Colors and styles

When you edit or define a style, the colors from which
you can choose are determined by the color palette
used by the template. All Visio Technical templates use
a default color palette, which you can change.

For details about changing a template’s color palette,
see Developing Visio Solutions. For details about edit-
ing colors to apply to a shape, search online Help for
“colors.”
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To define a new style:

1. From the Format menu, choose Define Styles.

2. In the Style dialog box, type a name for the new style.

3. If you want to base the new style on an existing style, under
Based On, choose that style.

4. Under Includes, check the attributes that your style
includes, so that the new style will be displayed in the
corresponding toolbar style lists.

5. Under Change, click Text, Line, or Fill to change the
settings for that attribute.

6. When the style contains the attributes you want, click
Apply.

A
B
C

D

E

F

G

Define Styles dialog box

A Type a name for a new style or choose the name of
the style you want to edit.

B Choose an existing style you want to base a new
style on. Editing the base style changes the new style
as well.

C Check the attribute classes (text, line, fill) that your
style includes, so that the style name will be dis-
played in the corresponding toolbar list.

D Click the Text, Line, or Fill button to define those
characteristics.

E Check here to preserve selected shapes’ special for-
matting—italic text, for example—even after you
apply the style.

F If shapes were selected when you chose Define Styles,
this button says Apply. If no shapes were selected, it
says OK. Click to create and apply a new style.

G Click to add a new style or change an existing one
and start creating or changing another.
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C R E A T I N G  N E W  S T E N C I L S

You aren’t limited to the stencils and templates that come with
Visio Technical. You can create your own.

Creating a new stencil can involve either adding or deleting
shapes from existing Visio stencils, or building entirely new
stencils using new shapes that you created from scratch and
saved in a stencil file.

It’s worthwhile to create a new stencil if:

• You frequently use shapes from several different Visio
stencils, and you want to consolidate them on one stencil.

• You’ve created shapes of your own that you plan to reuse or
share with others.

Often, stencils are stored with template files. When the tem-
plate is opened, the stencils open along with a drawing page
that has a scale, styles, and other features appropriate for the
shapes on the stencil. For details in this book about creating
templates, see “Creating New Templates” later in this chapter.

For more details about creating stencils and templates, see
Developing Visio Solutions.

About copyrighted SmartShapes

The SmartShapes supplied by Visio Corporation are
copyrighted. You may copy and reorganize them for
your own use, modify them for your own use, and dis-
tribute drawings that contain them. You may not sell
or distribute the original or modified SmartShapes.
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Methods for creating new stencils

To Do this

Base a new stencil on an existing stencil From the File menu, choose New. In the New section, choose Stencil.

From the Based On list, choose the stencil you want to base the new

stencil on, then click OK.

Create a new stencil from scratch From the File menu, choose New. In the New section, choose Stencil.

From the Based On list, choose No Stencil, then click OK.

Save a new stencil Click the stencil title bar to make it active. From the File menu,

choose Save As. In the Save Box, under Save, check Read Only to

protect the stencil from accidental changes. For Save As Type, choose

Stencil (*.VSS), name the file, then click Save.

Copy a master from one stencil to another Open both stencils, then drag the master from one stencil to another.

Copy or move a shape from the drawing To copy the shape, hold down the Ctrl key and drag the shape from

page to a stencil the drawing page onto the stencil. To move the shape, don’t hold

down the Ctrl key.

Creating stencils from local stencils

Whenever you create a drawing, Visio creates a local
stencil that includes all the shapes you use in the
drawing. You can save a local stencil as a standalone
stencil, so you can reuse it in other drawings.

To save a local stencil as a standalone
stencil:

1. From the Window menu, choose Show Master
Shapes to open the local stencil.

2. Click the drawing page title bar to make the draw-
ing page active. From the Edit menu, choose
Drawing Page, then choose Delete.

3. In the Delete dialog box, click a page, hold down
the Shift key and choose all other pages, then click
OK. The drawing pages disappear.

4. Save the local stencil using the procedure described
in the table above for saving stencils.
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C R E A T I N G  N E W  T E M P L A T E S

You usually create a template by setting up a drawing file the
way you want and then saving it in template format. You can
also open a copy of one of the templates that comes with Visio
Technical, revise it, and save it under a new name.

It’s worthwhile to create a new template if:

• You frequently use a particular combination of stencils.

• Your drawings involve customized settings for attributes
such as page size or scale, shape or text styles, color palette,
snap and glue, printing, or window size and position.

• Your drawings often use a standard background or set of
layers.

Keep these things in mind when you create templates:

• When you create a template from a drawing file, you may
not want the drawings in the file to remain in the template.
Open a copy of the drawing file, delete the drawings and
the shapes on the local stencil, and then save the copy as a
template.

• Make sure the shapes you intend to use in drawings based
on the template work well with the drawing scale you’ve
set. Masters can behave in unexpected ways if the scale
they’re drawn at differs significantly from the drawing page
scale. For shapes to behave correctly, the shapes and
drawing pages should use the same scale or one scale
should be no more than eight times greater than the other.

For details in this book about creating stencils, see “Creating
New Stencils” earlier in this chapter. For more details about
creating templates and stencils, see Developing Visio Solutions.

Opening copies of drawing files

If you want to preserve an original drawing file but
also base a new template on it, you can open a copy
of the drawing file rather than the original. From the
File menu, choose Open. In the Open dialog box,
choose the drawing file you want, then under Open,
click Copy.
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To create a template from a drawing file:

1. Open the drawing file and then open the stencils you want
to include in the template.

2. Arrange the stencil and drawing page windows the way you
want them to appear when you open the template to start a
new drawing.

3. Click the drawing window’s title bar to make it active, then
choose Save As from the File menu.

4. In the Save As dialog box, for Save As Type, choose
Template (*.VST), name the template, then click Save.

To revise an existing Visio template:

1. From the File menu, choose Open.

2. In the Open dialog box, locate and choose the template you
want to model the new template after. Under Open, make
sure Copy is checked, so a copy of the template, rather than
the original, opens.

3. Revise the settings and windows the way you want, then
choose Save As from the File menu.

4. In the Save As dialog box, for Save As Type, choose
Template (*.VST), name the template, then click Save.

Protecting templates from accidental changes

Templates have an automatic protection feature built in. When you open a template, you actually open a copy rather than the original. That way, if
you make setting and other changes, the original template still exists unchanged. You can also take additional steps to protect templates. From the
Tools menu, choose Protect Document. In the Protect Document dialog box, you can type a password to prevent unauthorized users from making
changes or specify which characteristics (for example, masters or styles) of a file you want to protect. For details about protecting your work, see
“Protecting Shapes and Files” in Chapter 7, “Sharing Drawings.”
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Measuring and Dimensioning

When precision counts, use Visio’s rulers, guides, grid lines,
and the Size & Position command to set the measurements you
need to draw and place shapes precisely. These and other
Visio Technical tools help you to create exact technical draw-
ings and to display and print measurements, rotation angles,
and other data.

Tip: Snap and glue are important settings for creating
drawings precisely. For details, see “Snapping and Gluing
Shapes” in Chapter 1 “Creating a Drawing.”

Topics in this chapter

Using the Grid........................................................................... 96

Using Rulers .............................................................................. 98

Setting Up Guides ..................................................................... 99

Precisely Sizing and Positioning an Object ........................... 100

Choosing and Setting a Drawing Scale .................................. 102

Using Dimension Lines to Show Size .................................... 104

Adding Geometry Fields ........................................................ 106

Calculating Perimeter and Area ............................................. 108
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U S I N G  T H E  G R I D

Each drawing page is criss-crossed by grid lines. You can con-
trol the grid spacing and also change the grid’s point of origin.
You can set spacing separately for the horizontal and vertical
grid lines. You can also set whether the grid is variable or fixed.

By default, Visio Technical uses a variable grid. Variable grid
lines change depending on the magnification at which you are
viewing your drawing. If you zoom in on your drawing, grid
lines may be closer together; if you zoom out, they may be fur-
ther apart. (You can check this by changing the magnification
and then looking at how the grid lines line up with the rulers.)
Visio determines the best grid spacing for the view. Variable
grids are very useful when you want to zoom in to align some-
thing precisely.

For some drawings, such as some floor plans and engineering
drawings, a variable grid isn’t appropriate. You can set a fixed
grid, so that grid lines stay the same distance apart regardless of
magnification. For example, you can set the grid to match the
size of ceiling tiles. If you set a fixed grid for tiles that are 40 cm
by 40 cm, you’ll notice the grid lines always match this distance
on the ruler, regardless of the magnification.

To place a shape more accurately, pause before
dragging. The line or outline will change to the
shape itself.
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Methods for working with grid lines

To Do this

Set grid spacing between lines for variable grids From the Tools menu, choose Ruler & Grid. Under Grid Spacing,

choose Fine, Normal, or Coarse for the horizontal and vertical rulers.

Change the spacing of the grid for a fixed grid From the Tools menu, choose Ruler & Grid. Under Minimum

Spacing, type the horizontal and vertical grid spacing you want.

Change the point where the grid From the Tools menu, choose Ruler & Grid. Under Grid Origin, type

originates (fixed grid only) the coordinates at which you want the grid to originate. By default,

the grid origin is in the lower-left corner of the drawing page.

Turn off the grid From the View menu, choose Grid to uncheck the Grid option.

Choose Ruler & Grid from the Tools menu to set a fixed grid.

To set a fixed grid:

1. From the Tools menu, choose Ruler & Grid.

2. In the Grid Spacing boxes, choose Fixed.

3. In the Minimum Spacing boxes, type the fixed grid spacing
you want, then click OK.

For more details about the grid, search online Help for “grid
lines.”

Ruler & Grid dialog box

A Choose Fixed to set a fixed horizontal and vertical
grid.

B Type the fixed grid spacing you want. Horizontal and
vertical spacing can differ. A

B
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U S I N G  R U L E R S

Each drawing page has vertical and horizontal rulers. For rul-
ers, you can specify both the units that appear on the ruler and
where the zero point, or starting point, of each ruler is. The
zero point is normally in the lower-left corner of the page, but
sometimes it’s helpful to move it to make it easier to measure
distances in a specific drawing. For example, you might want
the zero point to line up with a wall in a floor plan.

Methods for setting rulers

To Do This

Set ruler measurement units From the Edit menu, choose Drawing Page, then choose

Properties. In the Page Properties box, under Measurements,

choose the units you want, then click OK.

Change the position of the zero Hold down the Ctrl key, then drag from the intersection of the two

point on both rulers rulers to where you want the new zero point.

Change the position of the Hold down the Ctrl key, then drag from the other ruler.

zero point on one ruler

Return the zero point to the Hold down the Ctrl key, then double-click the intersection of

lower-left corner of the page the two rulers.

Change ruler subdivisions From the Tools menu, choose Ruler & Grid. Under Rulers, choose

the kind of subdivisions you want.

Hide the rulers From the View menu, choose Rulers to uncheck the Rulers option.

Note that when you move the zero point on a ruler, the grid
origin does not move with it. When you move the zero point,
the grid and ruler increments might become misaligned. For
details about adjusting the grid, see “Using the Grid” earlier in
this chapter.

Tip: To snap to ruler increments more easily, turn the grid
off.

0

0

To change the zero point on both rulers,
Ctrl+drag from the ruler intersection.
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S E T T I N G  U P  G U I D E S

When you need to precisely align several shapes and keep them
in the same position even when moving them, guides and
guide points are very useful. (Guide points are two short,
crossed lines.)

Aligning shapes with guides has two advantages over aligning
with the grid:

• Guides are easier to see because they are brighter than grid
lines.

• You can glue shapes to guides so that, when you move the
guide, all the shapes move with it. Therefore, you can do
things such as move a wall, and all the cabinets attached to
that wall, in one motion.

Methods for setting guides and guide points

To Do This

Place a guide on the drawing page Point to the ruler from which you want to drag a guide. Horizontal

guides come from the horizontal ruler and vertical guides from the

vertical ruler. Drag to where you want the guide.

Place a guide point on Point to the intersection of the two rulers. Drag to where you want

the drawing page the guide point.

Align shapes with Drag shapes until their selection handles, endpoints, or connection

guides or guide points points align with the guides or guide point.

Delete guides or guide points Click to select the guide or guide point you want to delete. From the

Edit menu, choose Clear.

For details about using a guide to move several shapes at once
while keeping them in the proper relationship to each other,
see “Moving Several Aligned Shapes at Once” in Chapter 2,
“More About Shapes.”

Guide points are two short, crossed guides that
you can use to align shapes at their corners or to
center shapes on top of one another.
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P R E C I S E L Y  S I Z I N G  A N D
P O S I T I O N I N G  A N  O B J E C T

By using the Size & Position command, you have precise con-
trol over a shape’s position on the page, its dimensions, and its
degree of rotation. If you want very specific control and feed-
back about a shape, or if you prefer to move and size shapes by
entering information rather than using the mouse, this com-
mand will be convenient and useful.

Size & Position options for 1-D shapes

Size & Position options for 2-D shapes

A
B

C

D

F

H

E

G

Size & Position (2-D) dialog box

A The width of the shape.

B The height of the shape.

C The shape’s current angle of rotation in relation to its parent.

D When checked, flips the shape horizontally.

E When checked, flips the shape vertically.

F Specifies the position of the x-coordinate of the shape’s pin in relation to the page.
Enter a new value to change the position of the pin.

G Specifies the position of the y-coordinate of the shape’s pin in relation to the page.
Enter a new value to change the position of the pin.

H Changes the location of the shape’s pin in relation to the page. Choose a section to
change the pin location.

Size & Position (1-D) dialog box

A Check to display the shape’s beginning and ending
points and its height in the Parameters section.

B Check to display the shape’s beginning point, angle of
rotation, length, and height in the Parameters sec-
tion. Visio calculates the ending point.

C Check to display the shape’s ending point, angle of
rotation, length, and height in the Parameters sec-
tion. Visio calculates the beginning point.

D Edit the x-coordinate, which describes the beginning
point of the 1-D shape in relation to the origin of its
parent.

E Edit the y-coordinate, which describes the beginning
point of the 1-D shape in relation to the origin of its
parent.

F Edit the x-coordinate, which describes the ending
point of the 1-D shape in relation to the origin of its
parent.

G Edit the y-coordinate, which describes the ending
point of the 1-D shape in relation to the origin of its
parent.

H The height of the shape.

A
B
C
D

E H

F
G
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To enter coordinates for a shape’s size and position:

1. Select the shape you want to modify.

2. From the Shape menu, choose Size & Position.

3. In the Size & Position dialog box, enter the coordinates you
want, then click OK.

Tip: When a shape’s size and position are displayed on the
status bar, you can click the status bar to open the Size &
Position dialog box.

For more details, search the online Help for “size & position
command.” For details about the the origin of a shape and of a
shape’s parent, see Developing Visio Solutions.

You can also accurately and evenly space several shapes by
using the Align Shapes, Distribute Shapes, or Array Shapes
Add-on command. For details, see “Duplicating Shapes” and
“Arranging Shapes” in Chapter 2, “More About Shapes.”

Viewing a shape’s precise size and position

When you drag shapes, guides, or guide points on the
drawing page, precise coordinates for the object’s posi-
tion appear in the status bar at the bottom of the
Visio window, and on the rulers, faint lines appear to
help you position the shape precisely. Also, the Size &
Position dialog box and the ShapeSheet provide details
about a shape’s location and size. For details about
the ShapeSheet, see Developing Visio Solutions.
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C H O O S I N G  A N D  S E T T I N G  A  D R A W I N G  S C A L E

Whenever you need to create the exact spatial relationships of
very small or very large objects in the space of a drawing page,
you need to set a drawing scale. For example, in an architec-
tural floor plan, the scale might be 1:50, and in a drawing of a
bolt, the scale might be 5:1.

In Visio Technical, drawing units are sizes in the real world.
Page units are sizes on the printed page. The ratio of page units
to drawing units is the drawing scale.

Some Visio templates (for example, space planning and land-
scape templates) open with a drawing scale already set. If you
want to work with a different drawing scale, you can change
the setting. You can also set a drawing scale in any Visio draw-
ing, whether it originally had a scale set or not.

Scale is a page property. In a multiple-page Visio drawing, each page can have
a different scale. Changing the scale of a drawing page doesn’t change the
scale of a background assigned to it.

When you set a drawing scale, ruler units reflect
scale units. To set ruler units that differ from
scale units, choose Drawing Page from the Edit
menu, then choose Properties.

ScaledUnscaled (1:1)

Masters and drawing scales

Within certain limits, Visio Technical masters adjust
automatically to the scale of a drawing page. If the
drawing scale of the master is no more than eight
times greater or smaller than the drawing scale of the
page, Visio scales it appropriately on the page. If the
scales differ too greatly, shapes can even expand off
the page. For more details about the range of eight
rule, see Developing Visio Solutions.
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To set a drawing scale:

1. Display the page for which you want to set a scale.

2. From the Edit menu, choose Drawing Page, then choose
Size & Scale.

3. In the Drawing Size/Scale dialog box, choose the scale
options you want, then click OK.

Choose Drawing Page from the Edit menu, then choose Size & Scale to set a
drawing scale for a drawing page.

Drawing Size/Scale dialog box

A Displays the current scale.

B Click to create an unscaled drawing.

C Click to choose a scale from a list of scales relevant
to a particular discipline.

D Click to enter a custom scale, then enter itin the
Scale edit box.

A
B

C

D

Change the magnification

You can zoom in on and out from a drawing by choosing a magnification from the Set Zoom list on the toolbar, but it’s faster to use the following
shortcuts:

Zoom in: Press Ctrl+Shift+left-click.

Zoom out: Press Ctrl+Shift+right-click.

Zoom in on a selected area: Hold down Ctrl+Shift+left mouse button and drag a rectangle around the area you want to zoom in on.

Scroll: Hold down Ctrl+Shift+right mouse button and drag the page.

In Visio, the magnification at which you view and work on a drawing is independent of the scale you set for a drawing page. Whatever your drawing
scale, you may still need to zoom in (change the magnification, for example, from 50% to 200%) on a portion of a drawing to position shapes ex-
actly or do other precise work.
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2.14 m

3 m

Dimension lines show the dimensions in drawing
units, regardless of how the page is scaled.

U S I N G  D I M E N S I O N  L I N E S  T O  S H O W  S I Z E

When you select a shape, its dimensions appear in the status
bar at the bottom of the Visio window and change as you resize
the shape. Sometimes, though, you want dimension informa-
tion to appear in your drawing.

The dimension lines masters on some Visio Technical stencils
calculate and display linear and angled dimensions. Glue one
of these dimension lines to another shape so that when you
resize the shape, dimensions are calculated automatically. For
details about a particular dimension line master, right-click it
on the stencil or drawing page, then choose Shape Help from
the shortcut menu.

You can also use dimension lines to ensure that the total of sev-
eral distances equals a certain length. To measure a series of
distances, you form dimension lines into a chain.

To glue a dimension line to a shape handle:

1. From the Tools menu, choose Snap & Glue.

2. In the Snap & Glue dialog box, under Currently Active,
check Glue.

3. Under Glue To, check Shape Handles.

4. Under Snap & Glue Strength, move the box on the Points
slider bar to increase or decrease the strength, then click
OK.

5. Drag a dimension line onto the drawing page and glue its
endpoints to selection handles on the shape you want to
measure.

54°

Angle dimension line

R 0.25

Radius or Diameter dimension line



M E A S U R I N G   A N D   D I M E N S I O N I N G 105

To form dimension lines in a chain:

1. Open a Dimension Lines stencil and a drawing page, if they
are not already open.

2. If you want, place guides on the page to mark off a series of
distances.

3. From the connector tool menu on the toolbar, choose the
stamp tool.

4. On the Dimension Lines stencil you opened, click the
Dimension Line shape you want to use.

5. Click the page where you want the first dimension line to
start (at the first guide), then drag to extend the dimension
line to the second guide.

6. To deselect the dimension line, press the Esc key.

7. Position the stamp tool on the second guide and drag to
the third guide.

8. Repeat steps 6 and 7 for subsequent dimension lines, until
all the dimension lines in the series are on the page.

Tip:  You might want to set snap and glue options before
you glue dimension lines to shapes. Depending on what
you are measuring, particular points might be more
appropriate to glue to than others.

5.00 3.00 1.50 4.00

Choose a dimension line to include in a chain.

Using dimension line SmartShapes

Visio Technical’s dimension line SmartShapes can auto-
matically calculate linear and angular dimensions in
your drawing. You can adjust how dimension values
are displayed by choosing the units of measure, frac-
tional or decimal values, and the precision of decimal
values. The units of measure for a dimension line can
differ from the units set for the drawing page.

To change how dimension values are displayed, right-
click a dimension line shape in your drawing, then
choose Precision & Units. To set other lines on the
same drawing page to the units set for a particular
dimension line, right-click the line with the units you
want, then choose Set As Default.
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A D D I N G  G E O M E T R Y  F I E L D S

To automatically update technical specifications in a drawing,
add geometry fields to shapes. After you’ve added a field, when
you resize or rotate a shape, Visio Technical automatically cal-
culates and displays the new height, width, angle, or rotation.

To add height and width dimension fields to a shape:

1. Select the shape to which you want to add dimensions.

2. From the Insert menu, choose Field.

3. In the Field box, under Category, choose Geometry, then,
under Field, choose Width.

4. Under Format, choose the format in which you want the
field information to appear, then click OK.

5. Choose the text tool and select the shape. Place the
insertion point after the width number and type “x.”

6. Follow steps 2 through 4 above, but choose Height instead
of Width.

7. Resize the shape. The dimensions change automatically.

illum 0.9144

When you create a geometry field, if nothing is
selected and the insertion point is not placed at a
specific location within the existing text, the field
text replaces any other text in the shape.

0.9144
0.9144

You can format and align field text the same way
you format any text.
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To add a rotation-angle field to a shape:

1. Select the shape you want to add a rotation-angle field to.

2. From the Insert menu, choose Field.

3. In the Field box, under Category, choose Geometry, then,
under Field, choose Angle. Under Format, choose Degrees,
then click OK.

4. From the toolbar, choose the rotation tool.

5. Place the pointer over a round selection handle and rotate
the shape. The rotation angle field records the angle of
rotation.

For more details about data fields and shape properties, see
“Adding Page Numbers and Other Data Fields” in Chapter 3,
“Adding Text to Drawings” and “Defining Custom Properties
for a Shape” in Chapter 8, “Customizing Shapes.” For details
about creating your own formulas for fields, see Developing
Visio Shapes.

0 deg.
-25 deg.

As you rotate a shape, its rotation-angle field
records the angle of rotation in positive or
negative numbers.
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C A L C U L A T I N G  P E R I M E T E R  A N D  A R E A

Visio Technical makes it easy to keep track of the total area in a
building plan or to calculate the cross-sectional area of parts of
a structure. Using the Measure Add-on, you can automatically
calculate the total perimeter and area of any closed shape or
any number of shapes. Also, if you are interested only in a
shape’s length and not the area, you can use this add-on to cal-
culate length for an open shape.

When you run the Measure Add-on, the Measure dialog box opens with the
perimeter and area of the selected shapes already calculated.

When an area you’re measuring includes empty space

You can subtract empty space from an area you want to measure. For example, if a floor plan includes a stairwell, you may want to subtract the
stairwell floor space. Draw a border around both the stairwell and the entire floor. Select the two shapes formed by the borders. From the Shape
menu, choose Operations, then choose Combine. This creates a hole in the floor the size of the stairwell. When you run the Measure Add-on, the area
of the hole will be subtracted from the area of the floor. For more details about Visio Technical’s merging operations, see “Merging Shapes to Create
New Ones” in Chapter 2, “More About Shapes.”

D

C
B

Measure dialog box

A Select the unit of measure you prefer from the area
and length (perimeter) lists.

B Click to calculate the area and perimeter.

C Click to highlight the areas in the drawing used in
the calculation.

D Click to copy the corresponding value to the Clip-
board, so you can paste it into the current shape,
the current drawing, or another document.

A
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To calculate perimeter and area:

1. From the Tools menu, choose Snap & Glue. Under Cur-
rently Active, check Snap. Under Snap To, check Shape
Vertexes and uncheck all other options.

2. Using one of Visio Technical’s drawing tools or a shape
from a stencil, draw a border around the perimeter of the
area you want to measure.

3. Make sure the first and last vertices of the border shape are
connected to create a closed shape. To measure multiple
areas, draw a separate border around the perimeter of each
area you want to measure.

4. Select the shape or shapes for the area you want to mea-
sure.

5. From the Tools menu, choose Run Add-on, then choose
Measure Add-on.

6. In the Measure dialog box, under Total Area and Total
Length, choose the units you want.

7. When you’re finished using the add-on, click Exit.
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Organizing Shapes with
SmartLayers

Use Visio Technical’s SmartLayers to organize related shapes on
a drawing page. You can selectively view, edit, print, or lock lay-
ers, and you can control whether shapes on a layer can be
snapped to or glued to. You can assign a single shape to mul-
tiple layers.

This chapter describes how to take advantage of Visio’s
SmartLayer behavior to organize shapes in drawings.

Topics in this chapter

Using Layers in Visio Technical .............................................. 112

Creating and Removing Layers .............................................. 114

Assigning Shapes to Layers ..................................................... 116

Controlling Shape Behavior Using Layers ............................. 118

Modifying Layer Assignments for Masters ............................ 120
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U S I N G  L A Y E R S  I N  V I S I O  T E C H N I C A L

A layer is a named category of shapes. Layers help organize
shapes in your drawing. For example, you can assign walls,
wiring, and furniture to different layers in a space plan. By
assigning shapes to layers, you can:

• Show, hide, or lock shapes on specific layers, so that you
can edit certain layers without affecting others.

• Select and print shapes based on their layer assignments.

• Temporarily change the display color of all shapes on a
layer to make them easier to identify.

• Assign a shape to more than one layer, as well as assign the
member shapes of a group to different layers.

A shape can be assigned to multiple layers or no layers. If you
change your mind about the layers you want in your drawing,
or the layers to which your shapes are assigned, you can modify
the drawing to match a new organization. Every page in a
drawing can have a different set of layers.

Wall layer Fixtures layer Tile layer

Shapes can belong to more than one layer. Here, the wall shapes belong to
the Wall, Fixtures, and Tile layers.
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Using layers to organize shapes

You can use layers to organize:

• Categories of related shapes that represent objects such as
furniture, electrical enclosures, equipment, and fans.

• Abstract or spatial relationships (such as West wing, second
floor, and AC power) or corporate organizations (account-
ing, engineering, and sales).

Using layers on backgrounds

A background is a page that appears behind another page and
can have its own set of layers. Because a background can be
shared by more than one page and layers cannot, there are
times you may want to use layers on both the foreground and
background pages. For example:

• In a drawing where the same map is used on multiple
pages, you can put the map on the background. If you want
to hide the roads on all the pages, you can hide the
background’s Road layer.

• In a drawing with a title block on the background, you can
hide the Revision History layer if you don’t want to print it.

• If the background includes information you don’t want
modified, such as your company logo and name, but you
need to give the file to your client for modifications, you
can lock the Corporate layer, then pass the file on to your
client.

Aliquam
erat

volutpat

Aliquam
erat

volutpat

Background Foreground Background and
foreground

When you open a Visio file, the drawing page on
the screen is a foreground page. If you want to
use backgrounds, you need to create them.
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C R E A T I N G  A N D  R E M O V I N G  L A Y E R S

Many Visio masters are already assigned to layers, so when you
add them to the page, the layer is added as well. You can create
new layers to organize custom categories of shapes, then assign
your shapes to those layers as well as to the layers that Visio au-
tomatically provides. For example, when you open a space
planning template, the masters are already assigned to the lay-
ers. As you drop instances of the masters, the layers of the space
plan are set up for you.

When you create a new layer, Visio Technical adds it only to the
current page, not to all pages in the file. Similarly, when you
create a new page, you must define its layers; the new page does
not inherit layers from the previous page. However, when you
copy a shape with a layer assignment from one page to another,
Visio adds the layer to the new page.

When you no longer need a layer, you can remove it. All shapes
assigned only to that layer are removed as well. If you don’t
want to remove the shapes along with layer, change or remove
each shape’s layer assignment before you remove the layer.

Tip: To see how many shapes are assigned to a layer, choose
Layer Properties from the View menu. In the Layer
Properties box, click the # button.

Wall layer Fixtures layer
5'

 - 
0"

7'
 - 

10
"

Tile layer Dimensions layer

5'
 - 

0"

7'
 - 

10
"

Entire bathroom drawing

Copying shapes on layers

When you copy a shape assigned to a layer, then
paste the shape onto another drawing page, the layer
is copied to the page as well as the shape. If the page
already has a layer with the same name, the shape is
added to the existing layer.
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To create a layer:

1. From the View menu, choose Layer Properties.

2. In the Layer Properties box, click New.

3. In the New Layer box, type a name for the layer, then
click OK.

4. In the Layer Properties dialog box, check the properties
you want the layer to have, then click OK.

For details about layer properties, see “Controlling Shape
Behavior Using Layers” later in this chapter.

To remove a layer:

1. From the View menu, choose Layer Properties.

2. To remove all layers that do not have shapes assigned to
them, check Remove Unreferenced Layers.

3. To remove other layers that may contain shapes, select the
layer you want to remove, then click Remove.

4. Click OK in the Layer Properties dialog box.

AutoCAD and layers

All AutoCAD drawings can contain layers. Typically,
companies that use AutoCAD have standard layers on
which specific shapes always appear. You can think of
AutoCAD layers as a stack of transparencies. In
AutoCAD, shapes appear on only one layer.

Although AutoCAD and Visio use layers differently, you
can convert a Visio file to AutoCAD format as long as
you assign all shapes to a layer, and do not assign
any shapes to multiple layers.

For details, see Chapter 9, “Converting AutoCAD and
Other File Formats.”
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A S S I G N I N G  S H A P E S  T O  L A Y E R S

If you create custom shapes in a drawing with layers, you can
assign those shapes to the drawing’s layers. If you create
instances of Visio masters (that is, the shapes created when you
drag and drop masters), the master may have a layer assign-
ment already that you want to change. You can select shapes
already on a drawing page, then assign them to one or more
layers. In a drawing with many shapes and layers, you may find
it more efficient to designate an active layer, so that all shapes
you subsequently draw or add are automatically assigned to
that layer.

When you create an instance of a master that is preassigned to
a layer, the instance inherits the master’s layer assignment. If a
layer of that name does not already exist on the drawing page,
creating the instance adds the layer as well. If you have desig-
nated an active layer for the page, that instance is assigned only
to the layer it inherited from its master shape, although you
can later assign it to the active layer or another layer.

Note: If a layer is locked against editing, you cannot make it the
active layer until you uncheck Lock in the Layer Properties dia-
log box.

Reporting on layered shapes

You can create a report that lists properties of shapes
based on their layer assignments.

For details, see “Generating a Report From Layered
Shapes” in Chapter 8, “Customizing Shapes.”


